Mame4all controller and Kodi audio problems

Post tips/tricks or get help with configuring RetroPie
Post Reply
User avatar
Chrisagu28
Posts: 101
Joined: Tue Mar 14, 2017 10:33 am
Has thanked: 41 times
Been thanked: 10 times

Mame4all controller and Kodi audio problems

Post by Chrisagu28 » Wed Aug 09, 2017 6:10 am

Hey Everybody,

I am finishing up the software side of my GBZ and I am using Kite's SAIO. Everything has been a breeze but I hit two snags on the software side. I am unable to map the GBZ control to MAME (using Mame4all) and I have no audio output in Kodi.

I followed the wiki's online and even searched on google, These two issues are stumping me.

For the Mame situation. I plugged in a keyboard and hit tab to bring up the menu, went to input (general) and when I try to change the input to the GBZ it does nothing. The keyboard is still recognized and works fine. All the other emulators haven't been a issue except this one.

For Kodi (I am using it for music and a video player for on the go) I have nice clean playback of movies and such but I can't get the audio working.

If anybody has any input or advice, Please let me know :)
Thanks.

User avatar
VeteranGamer
Posts: 1738
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 528 times
Been thanked: 905 times

Re: Mame4all controller and Kodi audio problems

Post by VeteranGamer » Wed Aug 09, 2017 7:06 am

Chrisagu28 wrote:
Wed Aug 09, 2017 6:10 am
Hey Everybody,

I am finishing up the software side of my GBZ and I am using Kite's SAIO. Everything has been a breeze but I hit two snags on the software side. I am unable to map the GBZ control to MAME (using Mame4all) and I have no audio output in Kodi.

I followed the wiki's online and even searched on google, These two issues are stumping me.

For the Mame situation. I plugged in a keyboard and hit tab to bring up the menu, went to input (general) and when I try to change the input to the GBZ it does nothing. The keyboard is still recognized and works fine. All the other emulators haven't been a issue except this one.

For Kodi (I am using it for music and a video player for on the go) I have nice clean playback of movies and such but I can't get the audio working.

If anybody has any input or advice, Please let me know :)
Thanks.

have you tried lr-mame2000 (i know mame4all is recommended but i've never got it to work properly on a pi0).... the controls should work without the need to set them up...

User avatar
Chrisagu28
Posts: 101
Joined: Tue Mar 14, 2017 10:33 am
Has thanked: 41 times
Been thanked: 10 times

Re: Mame4all controller and Kodi audio problems

Post by Chrisagu28 » Wed Aug 09, 2017 4:14 pm

Not Yet, I went with mame4all for that reason. It was recommended and compatible with most roms. I will try switching it out and seeing if that helps.

Thanks for the info

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest