How-to: Use USB Audio in Retropie v3.7

Various user-contributed guides for software-related things
drlbradley
Posts: 38
Joined: Wed Jun 01, 2016 1:00 am
Location: Windsor, UK
Has thanked: 12 times
Been thanked: 5 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by drlbradley » Tue Jun 21, 2016 7:58 am

nope, nothing.
going to abandon usb audio and do pwm :(

User avatar
Fleder
Posts: 848
Joined: Thu May 05, 2016 9:04 am
Location: Germany
Has thanked: 182 times
Been thanked: 257 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by Fleder » Tue Jun 21, 2016 8:17 am

What is your mixer called, then?
Can you do "alsamixer" in terminal or Audio over the retropie menu and write the name of the mixer?

marcushg
Posts: 37
Joined: Thu May 19, 2016 4:11 pm
Has thanked: 5 times
Been thanked: 4 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by marcushg » Thu Jun 23, 2016 5:36 pm

Mine is called Headphones... and is giving the same error every 3 or 4 seconds... I think it also affects to sound performance... tried to recompile all day but after an hour always give some error in help component. Cpp or not enough virtual memory. Haven't tried what fleder posted. Would be nice the idea of the "alias".

User avatar
Fleder
Posts: 848
Joined: Thu May 05, 2016 9:04 am
Location: Germany
Has thanked: 182 times
Been thanked: 257 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by Fleder » Fri Jun 24, 2016 12:09 am

Try the alias method. I haven't myself, but i heard it should work.

User avatar
hipposcottamus
Posts: 1
Joined: Thu Jul 28, 2016 11:55 am
Has thanked: 1 time

Re: How-to: Use USB Audio in Retropie v3.7

Post by hipposcottamus » Tue Aug 09, 2016 9:49 am

Great work Chiz! I've got the USB audio working great, however, I'm now struggling to get sound through HDMI. I've rebooted the system a few times with and without the HDMI cable in but it seems to consistently be searching for the USB audio input. Any ideas?

Pumpytums
Posts: 22
Joined: Wed Sep 14, 2016 8:55 am
Has thanked: 3 times
Been thanked: 6 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by Pumpytums » Tue Oct 04, 2016 1:44 am

Hi everyone,
I followed this guide and got the sound working on Snes Gameboy etc but it bombs on Mame has anyone got a USB sound card working ton that please?

Thanks

Heiser
Posts: 2
Joined: Tue Oct 04, 2016 3:43 pm

Re: How-to: Use USB Audio in Retropie v3.7

Post by Heiser » Tue Oct 04, 2016 3:55 pm

Hi guys.
I have a sound card creative emu0202.
I have installed on raspberry KODI system where the card is working normally,
and RETROPIE after using the commands of this post card also works but I have a problem because the sound is interrupted.
In KODI it was the same when I had the settings automatically:
ALSA: E-MU 0202 | USB, Analog
after switching on:
ALSA: E-MU 0202 | USB, S / PDIF
sound in the end was normal.
I suppose that the same must be done in retropie but the question is how?

User avatar
JujuPi
Posts: 51
Joined: Mon Nov 21, 2016 2:08 am
Has thanked: 8 times
Been thanked: 16 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by JujuPi » Thu Nov 24, 2016 9:54 pm

Working! Thanks habibi :)

:D :D :D

sfrooze
Posts: 1
Joined: Fri Nov 25, 2016 12:57 pm

Re: How-to: Use USB Audio in Retropie v3.7

Post by sfrooze » Fri Nov 25, 2016 1:02 pm

Thanx for the tutorial, is very useful. Can anyone confirm usb audio works with n64 emulator (mupen64plus). coz don't work in my Rpi :cry:
greetings.

jellybelly
Posts: 219
Joined: Wed Nov 16, 2016 3:04 am
Location: UK
Has thanked: 3 times
Been thanked: 73 times

Re: How-to: Use USB Audio in Retropie v3.7

Post by jellybelly » Sun Dec 04, 2016 11:09 am

Fleder wrote:For easier access and backup, i will post the solution here.
jcoutch wrote:Assuming you've already set the USB sound card as the default in Alsa, you should be able to do the following:
Open up a terminal prompt, and run:

amixer -l
Note the name of your mixer. Mine was named "Speaker".

Now run:

git clone https://github.com/Aloshi/EmulationStation.git
nano EmulationStation/es-app/src/VolumeControl.cpp

Change line 8 from:

const char * VolumeControl::mixerName = "PCM";
to match the name of your mixer ("Speaker" in my case):

const char * VolumeControl::mixerName = "Speaker";
Press Ctrl+O and Enter to save the file, then Ctrl+X to exit Nano.

Then, follow the instructions for building the code from the main Github page:
sudo apt-get install libsdl2-dev libboost-system-dev libboost-filesystem-dev libboost-date-time-dev libboost-locale-dev libfreeimage-dev libfreetype6-dev libeigen3-dev libcurl4-openssl-dev libasound2-dev libgl1-mesa-dev build-essential cmake fonts-droid

cd EmulationStation
cmake .
make
make install


Restart Emulation Station, and now you should be able to control your volume.
anyone help with this? ive ran the git clone, then i go into volumecontrol and the file is empty why is this?

as its empty i cant edit the bits that needto be changed to get rid of this error

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest