Uncanny Eyes Itsy Bitsy M0 Express board

Arduino-related hardware discussion (including Teensy and other Arduino clones)
Post Reply
SirLagsUhLot
Posts: 2
Joined: Thu Oct 01, 2020 11:24 am
Has thanked: 1 time

Uncanny Eyes Itsy Bitsy M0 Express board

Post by SirLagsUhLot » Thu Oct 01, 2020 11:34 am

New to this arduino code thing. Having a difficult time getting the uncanny eyes to work. Only working on one eye, it is all i need for the project. Not sure I have the right libraries and which lines to enable. Only thing i get from the board is a violet light when i plug it in and occasionally when i upload the code to the board the LED flashes. I have all the wires soldered except cs2 because i don't need more than one eye. Any help would be appreciated. Thanks!

averylw
Posts: 2
Joined: Thu Oct 22, 2020 7:03 am
Has thanked: 1 time
Been thanked: 1 time

Re: Uncanny Eyes Itsy Bitsy M0 Express board

Post by averylw » Thu Oct 22, 2020 7:11 am

I am working on this same project. just joined because I see alot of cool things that I plan on getting involved with. I am trying to do SETS of eyes and can only get one set to work at a given time. SO there is that problem. For your issue, you should make sure to download Wermys Github code. not the std Arduino Uncanny eyes. He actually preset everything and simplified it for ItsyBitysy Express M0 and TFT screens. I can assist and would like to hear how it goes since I am tackling same project. I added mine to some old black and white pictures and cut eyes out. pretty cool. I want to add second set to one and am struggling.

SirLagsUhLot
Posts: 2
Joined: Thu Oct 01, 2020 11:24 am
Has thanked: 1 time

Re: Uncanny Eyes Itsy Bitsy M0 Express board

Post by SirLagsUhLot » Mon Oct 26, 2020 11:34 am

Having trouble getting anything out of the tft display. The project is to show an eye when you open a small port door on a shelf. Making it look like someone is looking back at you. Have been using the github code from wermy. I keep enabling different lines of code to see if I can get it working.

averylw
Posts: 2
Joined: Thu Oct 22, 2020 7:03 am
Has thanked: 1 time
Been thanked: 1 time

Re: Uncanny Eyes Itsy Bitsy M0 Express board

Post by averylw » Tue Oct 27, 2020 11:52 am

Quick question are you using 5V or 3.7? Did you solder LED to vcc pin? because you should at least get the bright screen(background light) from that connection. Lastly, did you change the resistor on the tft? Just curious. because those things made a difference for me. so everytime i connect I at least get the backlight screen. I ended up nixing the second set of eyes. I tried to use ethernet cable and it would work sometimes, but only one set would generally work at a time.

Bzguy
Posts: 3
Joined: Sun Mar 07, 2021 3:08 am

Re: Uncanny Eyes Itsy Bitsy M0 Express board

Post by Bzguy » Sun Mar 07, 2021 3:15 am

hi all, I'm working on this too, but I only get 2 blank white screens :(

My setup is on a breadboard, all pins exactly connected as shown in Wermy's YouTube video. For the 1.44" SPI TFT, I changed the resistor too as per video and connected to VCC.

I'm using Wermy's github code for it, I didn't change anything there. CS1 connected to first eye, CS2 to the second one.

As a start, I tried the "blink sketch", that works.

I installed the necessary Arduino/Adafruit SAMD boards in Arduino IDE.

Uploading seems fine, no errors in Arduino IDE, however nothing on the screens, just blank white.

Bzguy
Posts: 3
Joined: Sun Mar 07, 2021 3:08 am

Re: Uncanny Eyes Itsy Bitsy M0 Express board

Post by Bzguy » Sun Mar 07, 2021 3:40 am

It's been a while since I made some kind of project, but I'm having issues too on this project :

I connected all exactly as per Wermy's YouTube video (including the resistor mod) , I'm using an ItsyBitsy M0 Express.
I'm using 2 1.44" 128x128 TFT SPI screens (1 connected to CS1, the 2nd to CS2), Arduino with all Arduino/Adafruit SAMD boards installed (through Arduino IDE), I'm using Wermy's github code. I get no Arduino IDE errors on upload.

Result : 2 blank white screens, nothing else

What am I doing wrong ?

Bzguy
Posts: 3
Joined: Sun Mar 07, 2021 3:08 am

Re: Uncanny Eyes Itsy Bitsy M0 Express board

Post by Bzguy » Sun Mar 07, 2021 8:32 am

My appologies, double post ;)

I did some "digging around", and read that these boards (Chinese red TFT boards) are known to sometime give troubles ... :(

I connected to an Arduino, loaded a sketch and when I press the reset button on Arduino, I can see briefly the screen working. For the rest it stays white/blank.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest