ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Discussion about other hardware (including other Pi-like boards)
User avatar
markolomew
Posts: 60
Joined: Wed Aug 23, 2017 1:31 pm
Location: Houston, Texas
Has thanked: 37 times
Been thanked: 35 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by markolomew » Fri Oct 26, 2018 2:07 pm

Soldered the small pcb directly to the gpio pins. It's definetly a better connection now as the screen doesn't flicker at all anymore, but it's still just a white screen still. I'm going to try re-imaging the SD card shortly to see if that helps.

In the meantime, I'm relooking over all the scripts we're to use and I have a question on this one (below), is it correct as is, or do we need to change anything. Other than that, open to suggestions :)

Code: Select all

sudo modprobe fbtft_device custom name=fb_ili9341  gpios=reset:25,dc:24,led:18 speed=16000000 bgr=1
Check out my builds: Click Here
Free .STL files for 3DS/PSP joystick cap mashup: Click Here
Check out my store, 8bitmark.com: Click Here

User avatar
VeteranGamer
Posts: 1703
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 498 times
Been thanked: 883 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by VeteranGamer » Fri Oct 26, 2018 2:11 pm

markolomew wrote:
Fri Oct 26, 2018 2:07 pm
Soldered the small pcb directly to the gpio pins. It's definetly a better connection now as the screen doesn't flicker at all anymore, but it's still just a white screen still. I'm going to try re-imaging the SD card shortly to see if that helps.

In the meantime, I'm relooking over all the scripts we're to use and I have a question on this one (below), is it correct as is, or do we need to change anything. Other than that, open to suggestions :)

Code: Select all

sudo modprobe fbtft_device custom name=fb_ili9341  gpios=reset:25,dc:24,led:18 speed=16000000 bgr=1
this is the only part you really need to edit, just to get better performance....

Code: Select all

speed=16000000

anything around....

Code: Select all

speed=90000000

slightly higher for better performance (but not higher than 99000000)....

if you get any sort of screen flickering, just drop it a little....


.

User avatar
markolomew
Posts: 60
Joined: Wed Aug 23, 2017 1:31 pm
Location: Houston, Texas
Has thanked: 37 times
Been thanked: 35 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by markolomew » Fri Oct 26, 2018 2:42 pm

Ok, tried increasing the speed to 90000000 like you mentioned, so far nothing but white screen. I'm noticing that the screen turn on (white) as soon as power is added to the pi. If I run a shutdown script and the pi turns off, the screen still stay on until i physically pull the power. Does that hint to anything (other than my frustration?).
Check out my builds: Click Here
Free .STL files for 3DS/PSP joystick cap mashup: Click Here
Check out my store, 8bitmark.com: Click Here

User avatar
VeteranGamer
Posts: 1703
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 498 times
Been thanked: 883 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by VeteranGamer » Fri Oct 26, 2018 3:13 pm

markolomew wrote:
Fri Oct 26, 2018 2:42 pm
Ok, tried increasing the speed to 90000000 like you mentioned, so far nothing but white screen. I'm noticing that the screen turn on (white) as soon as power is added to the pi. If I run a shutdown script and the pi turns off, the screen still stay on until i physically pull the power. Does that hint to anything (other than my frustration?).

the screen will always have power until you completely kill it....

i have a feeling that you've either got....

a connection issue with the screen and the board (maybe the ribbon cable isn't seated properly)
have you tried thicking the ribbon cable with some tape, or even checking if its hitting the correct points on the connector
(or the cable you have between the RPi and the Board is just too long)

or

you haven't installed the script property....
you should get indicators when installing if everything is working as it should (the display should switch)



your solder work looks good to me, and power is being provided to the screen (or you would get the back light turning on)
i can appreciate that its a bit frustrating...
bit you do have a simple issue its just a case of figuring out what it is



.

User avatar
markolomew
Posts: 60
Joined: Wed Aug 23, 2017 1:31 pm
Location: Houston, Texas
Has thanked: 37 times
Been thanked: 35 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by markolomew » Fri Oct 26, 2018 3:38 pm

Agreed! I'll find that bugger though. Thank you for your input. I'll get right on it!
Check out my builds: Click Here
Free .STL files for 3DS/PSP joystick cap mashup: Click Here
Check out my store, 8bitmark.com: Click Here

User avatar
markolomew
Posts: 60
Joined: Wed Aug 23, 2017 1:31 pm
Location: Houston, Texas
Has thanked: 37 times
Been thanked: 35 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by markolomew » Fri Oct 26, 2018 9:03 pm

Alive and Working! Who would have guessed, the masking tape did the trick. Turns out I "specifically" needed the masking tape on the monitor ribbon cable, not the ribbon cable between the pi and the pcb. WORKING! Great job and huge thank you!!

Also, I found it helped to not ssh into the pi to install everything. For whatever reason, directly installing from the unit itself did better.
Check out my builds: Click Here
Free .STL files for 3DS/PSP joystick cap mashup: Click Here
Check out my store, 8bitmark.com: Click Here

User avatar
markolomew
Posts: 60
Joined: Wed Aug 23, 2017 1:31 pm
Location: Houston, Texas
Has thanked: 37 times
Been thanked: 35 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by markolomew » Sat Nov 10, 2018 12:26 pm

Since we are all using the same screen/cables/and hardware, hopefully someone else has come across this issue: Screen lag.

I'm running a pi3 with the ili9341 screen with all parts specified to get from this original post. I've upped the speed=90000000 as instructed as well off of the post on page4. Anyway, screen is working, everything looks lovely, but there is a noticeable lag on the screen (as it if it not running at full speed). I keep my setup the same, but plugged in an HDMI into the pi3 hdmi port to my tv and it ran perfect. It even rescaled my screen on the ili9341 which was way squished, but it then ran at full speed. So, I shut down the unit, unplugged the hdmi cable from the pi, then turned it back on to find the lag was back.

At first I thought it was bc of the pi0 i was using, so I hooked up a pi3b+ to it instead, but the lag as still there.

Anyone have any ideas????
Check out my builds: Click Here
Free .STL files for 3DS/PSP joystick cap mashup: Click Here
Check out my store, 8bitmark.com: Click Here

User avatar
VeteranGamer
Posts: 1703
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 498 times
Been thanked: 883 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by VeteranGamer » Sat Nov 10, 2018 12:41 pm

markolomew wrote:
Sat Nov 10, 2018 12:26 pm
Since we are all using the same screen/cables/and hardware, hopefully someone else has come across this issue: Screen lag.

I'm running a pi3 with the ili9341 screen with all parts specified to get from this original post. I've upped the speed=90000000 as instructed as well off of the post on page4. Anyway, screen is working, everything looks lovely, but there is a noticeable lag on the screen (as it if it not running at full speed). I keep my setup the same, but plugged in an HDMI into the pi3 hdmi port to my tv and it ran perfect. It even rescaled my screen on the ili9341 which was way squished, but it then ran at full speed. So, I shut down the unit, unplugged the hdmi cable from the pi, then turned it back on to find the lag was back.

At first I thought it was bc of the pi0 i was using, so I hooked up a pi3b+ to it instead, but the lag as still there.

Anyone have any ideas????

you can try notching the speed up to 99000000 (if it starts getting glitchy, just knock it down a little)
(but you are already near the max, so not sure how much difference it will make)

what length cable are you also using?.....



.

User avatar
markolomew
Posts: 60
Joined: Wed Aug 23, 2017 1:31 pm
Location: Houston, Texas
Has thanked: 37 times
Been thanked: 35 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by markolomew » Sat Nov 10, 2018 2:54 pm

I did some googling and the issue is with the SPI driver for the ili9341 that is being used (fbcp), so I did some googing and found another driver that I ending up getting to work amazingly (with both a pi0w and a pi3b+). To save you some time, I'll post my code below for easy install:

Code: Select all

git clone https://github.com/juj/fbcp-ili9341.git
cd fbcp-ili9341
mkdir build
cd build
cmake -DSPI_BUS_CLOCK_DIVISOR=6 -DILI9341=ON -DGPIO_TFT_DATA_CONTROL=24 -DGPIO_TFT_RESET_PIN=25 -DGPIO_TFT_BACKLIGHT=18 -DSTATISTICS=0 ..
make -j
sudo ./fbcp-ili9341
Check out my builds: Click Here
Free .STL files for 3DS/PSP joystick cap mashup: Click Here
Check out my store, 8bitmark.com: Click Here

User avatar
VeteranGamer
Posts: 1703
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 498 times
Been thanked: 883 times

Re: ili9341 SPI TFT Screen Connectors (for bare screens without boards)

Post by VeteranGamer » Sat Nov 10, 2018 3:57 pm

markolomew wrote:
Sat Nov 10, 2018 2:54 pm
I did some googling and the issue is with the SPI driver for the ili9341 that is being used (fbcp), so I did some googing and found another driver that I ending up getting to work amazingly (with both a pi0w and a pi3b+). To save you some time, I'll post my code below for easy install:

Code: Select all

git clone https://github.com/juj/fbcp-ili9341.git
cd fbcp-ili9341
mkdir build
cd build
cmake -DSPI_BUS_CLOCK_DIVISOR=6 -DILI9341=ON -DGPIO_TFT_DATA_CONTROL=24 -DGPIO_TFT_RESET_PIN=25 -DGPIO_TFT_BACKLIGHT=18 -DSTATISTICS=0 ..
make -j
sudo ./fbcp-ili9341


That’s great news....

This code has already been posted on here...
(As well as google, a search on the forum is also a good idea)


Thanks....



.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest