Change 3.5" HDMI display boot logo

Discussion about other hardware (including other Pi-like boards)
User avatar
Marty33
Posts: 145
Joined: Wed Feb 22, 2017 4:55 pm
Has thanked: 19 times
Been thanked: 13 times

Re: Change 3.5" HDMI display boot logo

Post by Marty33 » Sat Dec 01, 2018 6:32 pm

i don't edit my first post if it can help VeteranGamer.

After edit 115200 by 9600 in RTD266xArduino.ino and specify 9600 in Baud Rate, i can connect and read status :
Connection successful!
Reading status info... done
Manufacturer ID: 0xC8 (Bright Moon Semiconductor Co., Ltd)
Device ID: 0x12 (T25S40)
JEDEC Manufacturer ID: 0xC8 (Bright Moon Semiconductor Co., Ltd)
JEDEC Memory Type: 0x40
JEDEC Capacity: 0x13 (512 KB)
Status: 0xFF9C
Only problem... impossible to finish the job.
For tests, i modify the background. It's slow, it takes 9 minutes to get to 100% and says to me:
Creating firmware backup file "firmware-2018-12-02-02-29-05.bin"... ok
Checking firmware... Error! Could not detect firmware.

floppes
Posts: 36
Joined: Thu Apr 19, 2018 5:58 am
Has thanked: 2 times
Been thanked: 32 times

Re: Change 3.5" HDMI display boot logo

Post by floppes » Sun Dec 02, 2018 3:28 am

Marty33, good to see it working. I will update the software to use 9600 baud. 115200 seems to cause problems for some users.

About the unknown firmware: The GUI tool "knows" only a few firmware variants. This is a precaution not to modify every firmware and corrupting it. You can send me the file firmware-2018-12-02-02-29-05.bin to floppes @ gmx . de and I will check it. If it matches the pattern of the other firmwares, I will add it and allow to modify it.

User avatar
Marty33
Posts: 145
Joined: Wed Feb 22, 2017 4:55 pm
Has thanked: 19 times
Been thanked: 13 times

Re: Change 3.5" HDMI display boot logo

Post by Marty33 » Sun Dec 02, 2018 6:20 am

I send the firmware. Hard to wait an update :-)

I pause the project because after that it will be difficult to access the HDMI port.

floppes
Posts: 36
Joined: Thu Apr 19, 2018 5:58 am
Has thanked: 2 times
Been thanked: 32 times

Re: Change 3.5" HDMI display boot logo

Post by floppes » Sat Dec 08, 2018 8:40 am

I have just released a new version of both the Arduino code and the GUI tool. Both need to be updated.

I have added checksums to the telegrams to make the communication more reliable. The connection problems should be solved as well. Sometimes the first few bytes from the Arduino don't reach the PC. Therefore the GUI tool makes 5 connections attemps where in most cases the first or second attempt succeeds.

I have not changed the baud rate as it takes 10 minutes to download the firmware with 9600 baud (about 1 minute @ 115200 baud). The "high" baud rate should not be an issue as the connection problems should be solved now.

floppes
Posts: 36
Joined: Thu Apr 19, 2018 5:58 am
Has thanked: 2 times
Been thanked: 32 times

Re: Change 3.5" HDMI display boot logo

Post by floppes » Tue Apr 02, 2019 1:35 pm

I have updated the project to v2.0 and added a Python script. This script allows you to read and write the firmware from a Raspberry Pi through a regular HDMI cable. No modified cable needed. You just need to enable the second I2C interface on the Pi, the GitHub page explains how this is done.

With the Python script you can read the firmware into a file. This file can then be loaded into the GUI tool where you can modify the boot logo, colors and "HDMI" popup. Transfer the modified file back to the Raspberry Pi and use the script to flash it into the display. This makes it all a lot easier and there is no additional hardware required.

Mikawal
Posts: 8
Joined: Fri May 03, 2019 8:17 am
Location: Malawi
Contact:

Change 3 5" HDMI display boot logo

Post by Mikawal » Mon May 20, 2019 10:07 am

My display resolution of 800x480, it has 18 bit color.
u-boot version: On branch patches-2014.10

I am using a modified version of wandboard.h.
Using this configuration I get a wandboard logo if I connect a hdmi display to the system.

I was able to get the display to work using your suggestions,

I will post the changes in another reply in case it can help someone else.

Thanks for the help.

Neville

solaris
Posts: 3
Joined: Mon Jul 15, 2019 1:46 pm

Re: Change 3.5" HDMI display boot logo

Post by solaris » Mon Jul 15, 2019 1:59 pm

Hi,
I recently started my GBZ project and I wanted to flash my display too.
Unfortunately I get the message

Resetting device...
Entering ISP mode...
Reading chip data...
JEDEC ID: 0x5e6013
Cannot setup chip commands! The flash chip id is unknown.

and nothing happens. The LCD seems to be a KeDei version 1.1 2019/5/8 and the ribbon is telling me LGH-3905.

Any idea?

floppes
Posts: 36
Joined: Thu Apr 19, 2018 5:58 am
Has thanked: 2 times
Been thanked: 32 times

Re: Change 3.5" HDMI display boot logo

Post by floppes » Tue Jul 16, 2019 1:26 am

There seems to be a different EEPROM on your board. It should be compatible with the known ones.

If you are familiar with coding, you can add your JEDEC ID in the code and it should work. Or just replace 0x1C3113 in line 47 of rtd266x.cpp with your ID.

Are you sure it says LGH-3905? I've seen LGH-3509. Maybe a typo?

solaris
Posts: 3
Joined: Mon Jul 15, 2019 1:46 pm

Re: Change 3.5" HDMI display boot logo

Post by solaris » Tue Jul 16, 2019 10:53 pm

Hi, yes you are right. It is 3509.
I will check later If modifying the code will work.

But thank you very much until now :)

Ah one remark: I am using the Python Script. Can you tell me what I have to change here?

solaris
Posts: 3
Joined: Mon Jul 15, 2019 1:46 pm

Re: Change 3.5" HDMI display boot logo

Post by solaris » Wed Jul 17, 2019 11:30 am

Ok, i got it to work with the python script to extract the software. I gave the jedec ID you mentioned and was able to download it.
But now I have the situation that the Windows app (I dont have and arduino unfortunately) keeps telling me "Error. Unknown firmware".

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest