powering question

General mintyPi-related chat goes here. Share ideas, ask questions that don't fit into the hardware/software help forums, etc.
Post Reply
deth502
Posts: 2
Joined: Wed Dec 05, 2018 9:34 am
Been thanked: 1 time

powering question

Post by deth502 » Wed Dec 05, 2018 10:28 am

new to all this, checked the faq (which had no tech questions) and saw nothing... bare with me for a bit of backstory...

no, really, VERY new to all this. i had been thinking of building something like this for a while, but theres always some obstacle (usually my ignorance being the biggest) yesterday i decided to bite the bullet and order a 3d printer. i had been looking at a few "in the controller" systems built on youtube and i decided to just go for it. so, since then, i have been looking at other builds, mainly because i see a hdmi cable AND a power cord hanging off the controller to be a major drawback. so this got me thinking of just throwing a lipo in it.

then i came across your video from july of 17 for the minty pi. i was looking at the power 5oo module thing, but as you clearly kow, space is a premium. i saw you chose the smaller charge circuit without the boost converter. this was one of my major stumbling blocks in that i needed to fit all of that in, so i thought, becaus from my research, the pi zero would not run on a 3.7v lipo battery, yet, again, in your video, it seems like you are running your pi directly off the 3.7v lipo. the oficiol pi page stated that the pi cut out just below 4.8v. what am i missing here?

small side note, another concern was that the pi page states a 1A min power supply, and again, was looking at the 500mA supply like you used, but i suppose that would be a non issue with your 1200mA battery. but will a 500mA battery really run it or will i need more?

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2393
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1266 times
Been thanked: 2914 times

Re: powering question

Post by Helder » Thu Dec 06, 2018 3:27 am

The Pi Zero needs 5v only for usb devices everything else on the Pi runs off of 3.3v so anything above 3.3v is regulated down to 3.3v which is why a battery can power it no problem.

The Powerboost 500c supplies 500mAh to the battery for charging it NOT the output to the Pi which comes from the battery itself. I think the battery provides around 2A but I might be wrong here.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

deth502
Posts: 2
Joined: Wed Dec 05, 2018 9:34 am
Been thanked: 1 time

Re: powering question

Post by deth502 » Thu Dec 06, 2018 7:31 pm

ok, so since no usb controller is hooked to this and it uses the board that hooks directly to the i/o pins it dosent "need" 5v then.

after i posted i kept going back to the pi site and the video trying to see what i missed. i still see that this works without a boost converter, but i thnk the error in my ways is in the fact that the pi website, although the page is supposed to be for all products, was mainly talking about the larger versions, and not the zero, when mentioning voltage tolerances.

now that i see how this is working i have many other questions, mainly involving wht is needed for this build and sources, but instead of being the annoying noob,i will check the faq for them, i had noticed seeing most of the answered i seek there.

thanks,

Post Reply

Who is online

Users browsing this forum: No registered users and 17 guests