[RESOLVED] MintyPi shutting itself off immediately after boot

Having trouble with your mintyPi build? Post your questions here!
Post Reply
Nukesnipe
Posts: 7
Joined: Fri Apr 02, 2021 10:57 pm

[RESOLVED] MintyPi shutting itself off immediately after boot

Post by Nukesnipe » Sat Apr 03, 2021 12:03 pm

It was working fine, I was trying to fix the issue with GBA games having slowdown, but then it just shut itself off. I got the screen as if I waved the magnet over the lil sensor thingy, so I turned it back on. Then it immediately shut itself off again. At this point it doesn't even get to the screen where I can start pressing buttons, it does the RetroPie splash and then immediately shuts down. There's no magnet next to the sensor, right now I have it wide open because I unscrewed the faceplate to facilitate taking the SD card out. Any ideas?

Edit: Turns out the charging chip on the PCB was bad, Helder sent me a new one and it works just fine now.
Last edited by Nukesnipe on Sat Apr 10, 2021 9:20 pm, edited 1 time in total.

DoubleDamageXX
Posts: 4
Joined: Fri May 11, 2018 8:39 pm

Re: MintyPi shutting itself off immediately after boot

Post by DoubleDamageXX » Sat Apr 03, 2021 9:20 pm

First thing i would do is check for continuity.

Nukesnipe
Posts: 7
Joined: Fri Apr 02, 2021 10:57 pm

Re: MintyPi shutting itself off immediately after boot

Post by Nukesnipe » Sun Apr 04, 2021 12:01 am

DoubleDamageXX wrote:
Sat Apr 03, 2021 9:20 pm
First thing i would do is check for continuity.
That's not the issue, like I said it was working just fine for a while. I think the issue is that the USB type-C cable I got isn't the exact right one and the battery wasn't actually charging when I had it plugged in. I was running by plugging a USB directly into the Pi0 earlier and it worked just fine. I ordered a new cable off Amazon and it should be here on Monday or Tuesday, hopefully that one is the right flavor.

Nukesnipe
Posts: 7
Joined: Fri Apr 02, 2021 10:57 pm

Re: MintyPi shutting itself off immediately after boot

Post by Nukesnipe » Mon Apr 05, 2021 8:10 pm

So update, I've bought a new cable that actually seems to charge the battery, the green light was on all the time until I unplugged it. I've tested the battery and it shows 3.7v, but immediately after boot it just shuts off no matter what. I get the RetroPie splash, it flashes a tiny icon in the top right that looks like a low battery icon, then immediately shuts itself down. I'll leave it plugged in overnight and see if it just takes a lot longer to charge.

Nukesnipe
Posts: 7
Joined: Fri Apr 02, 2021 10:57 pm

Re: MintyPi shutting itself off immediately after boot

Post by Nukesnipe » Tue Apr 06, 2021 9:32 am

So I let it charge all night and the exact same thing is still happening. At this point I don't think it's the cable, I don't think the battery itself is getting any power. I really have no idea where to go from here, help?

Nukesnipe
Posts: 7
Joined: Fri Apr 02, 2021 10:57 pm

Re: MintyPi shutting itself off immediately after boot

Post by Nukesnipe » Tue Apr 06, 2021 11:18 pm

Another update, talking with Helder in the discord has us certain it's the charging chip that's bad. He's sending me a replacement, and I'll see if that works when it gets here.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest