Black Screen then White Screen

Having trouble with your mintyPi build? Post your questions here!
User avatar
Sir_Holland
Posts: 11
Joined: Fri Aug 04, 2017 11:57 am
Been thanked: 2 times

Black Screen then White Screen

Post by Sir_Holland » Fri Aug 04, 2017 12:17 pm

Hello, been lurking the hardware help section but not finding the problem I've been having.

Followed the build guide step by step testing plenty along the way. Thing is, now that I have everything together in the tin, when I go to boot from battery power I get a black screen. I know the screen is getting power because the backlight is on. If I press the start button at any time, the black screen goes white similar to the problem everyone is seeming to have with the white screen. Tested the setup off the battery through HDMI, everything runs perfectly.

What's strange, is that I actually had it running on the screen before moving on to the battery and sound card steps. Something to note however, it did take a little messing around with the screen ribbon cable before it did.

I've quadruple checked continuity between my pi and the pcb board, everything seems good. Battery is fully charged, getting the green light according to the micro lipo. I do have a couple questions though.

Is the green light on the pi for boot supposed to come on under battery power? It does when I plug a usb into the pi directly. If not, am I not getting enough power from the battery to the pi so it won't boot? If I plug a usb into the pi with the screen plugged in, it will not turn on, I am assuming that is because the micro lipo is hooked up?

I've been messing with the screen ribbon cable so much I'm starting to think it's not the issue.
Attachments
IMG_8533.JPG
IMG_8533.JPG (2.44 MiB) Viewed 1974 times
IMG_8532.JPG
IMG_8532.JPG (2.32 MiB) Viewed 1974 times
IMG_8531.JPG
IMG_8531.JPG (1.88 MiB) Viewed 1974 times
IMG_8530.JPG
Screen is actually on, backlight is on.
IMG_8530.JPG (1.59 MiB) Viewed 1974 times
IMG_8529.JPG
IMG_8529.JPG (2.11 MiB) Viewed 1974 times
IMG_8528.JPG
IMG_8528.JPG (1.63 MiB) Viewed 1974 times
IMG_8527.JPG
IMG_8527.JPG (1.85 MiB) Viewed 1974 times
IMG_8526.JPG
IMG_8526.JPG (1.91 MiB) Viewed 1974 times

User avatar
Holydohnut
Posts: 194
Joined: Wed May 10, 2017 2:02 pm
Has thanked: 29 times
Been thanked: 68 times

Re: Black Screen then White Screen

Post by Holydohnut » Fri Aug 04, 2017 1:53 pm

Do you have a multimeter? Check that the connection between the battery and the charge board is giving out around 4 volts, and do the same on the two cables coming from the charge board. It's hard to see, (as it's covered in glue?) but if you don't get a good battery to charge board connection, you won't get 4 volts at the output point.

User avatar
Sir_Holland
Posts: 11
Joined: Fri Aug 04, 2017 11:57 am
Been thanked: 2 times

Re: Black Screen then White Screen

Post by Sir_Holland » Fri Aug 04, 2017 2:12 pm

Holydohnut wrote:
Fri Aug 04, 2017 1:53 pm
Do you have a multimeter? Check that the connection between the battery and the charge board is giving out around 4 volts, and do the same on the two cables coming from the charge board. It's hard to see, (as it's covered in glue?) but if you don't get a good battery to charge board connection, you won't get 4 volts at the output point.
Didn't want to risk a short with everything so close together, lol!

I do have a multimeter, and just checked. getting a solid 4 volts from the battery to the charge board. Additionally, I am also getting 4 volts to the button PCB as well.

User avatar
Holydohnut
Posts: 194
Joined: Wed May 10, 2017 2:02 pm
Has thanked: 29 times
Been thanked: 68 times

Re: Black Screen then White Screen

Post by Holydohnut » Fri Aug 04, 2017 3:17 pm

Hmmm... If it works fine via battery over hdmi, but the additional load of the screen is preventing the pi from booting then there must be a drain or a short somewhere. Did you see this post that Helder put on? Wondering it that could be an issue? http://www.sudomod.com/forum/viewtopic.php?f=34&t=3504
Presumably the pi activity light comes on when powered by battery and output to hdmi?

User avatar
Sir_Holland
Posts: 11
Joined: Fri Aug 04, 2017 11:57 am
Been thanked: 2 times

Re: Black Screen then White Screen

Post by Sir_Holland » Fri Aug 04, 2017 3:53 pm

Holydohnut wrote:
Fri Aug 04, 2017 3:17 pm
Hmmm... If it works fine via battery over hdmi, but the additional load of the screen is preventing the pi from booting then there must be a drain or a short somewhere. Did you see this post that Helder put on? Wondering it that could be an issue? http://www.sudomod.com/forum/viewtopic.php?f=34&t=3504
Presumably the pi activity light comes on when powered by battery and output to hdmi?
So, tried Helder's post with the ground wire, nothing changed. Tested continuity prior and there were no issues.

So I just tried your last suggestion. HDMI with battery, no boot. HDMI with USB plugged into pi... booted right up!

Pi is not getting power from the battery!

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2815
Joined: Thu May 05, 2016 8:33 am
Location: Rogers, AR
Has thanked: 1424 times
Been thanked: 3082 times

Re: Black Screen then White Screen

Post by Helder » Fri Aug 04, 2017 4:09 pm

Sounds like you don't have a solid connection on the 5V GPIO if it's not being powered on by the battery, is the battery also fully charged?
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
Sir_Holland
Posts: 11
Joined: Fri Aug 04, 2017 11:57 am
Been thanked: 2 times

Re: Black Screen then White Screen

Post by Sir_Holland » Fri Aug 04, 2017 4:41 pm

Helder wrote:
Fri Aug 04, 2017 4:09 pm
Sounds like you don't have a solid connection on the 5V GPIO if it's not being powered on by the battery, is the battery also fully charged?
Battery is fully charged,

5v is showing continuity on nearly all of the test pads on the controller pcb.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2815
Joined: Thu May 05, 2016 8:33 am
Location: Rogers, AR
Has thanked: 1424 times
Been thanked: 3082 times

Re: Black Screen then White Screen

Post by Helder » Fri Aug 04, 2017 4:58 pm

5V GPIO (it's on the silk screen) has continuity to the Power Input VCC? does the 3.3V GPIO have continuity to the VCC under the 8pin connector? does that VCC under the 8pin have continuity to the VCC pad on the LCD board? Finally what is the voltage at on the VCC and GND pads on the lcd board?
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
Sir_Holland
Posts: 11
Joined: Fri Aug 04, 2017 11:57 am
Been thanked: 2 times

Re: Black Screen then White Screen

Post by Sir_Holland » Fri Aug 04, 2017 6:20 pm

Helder wrote:
Fri Aug 04, 2017 4:58 pm
5V GPIO (it's on the silk screen) has continuity to the Power Input VCC? does the 3.3V GPIO have continuity to the VCC under the 8pin connector? does that VCC under the 8pin have continuity to the VCC pad on the LCD board? Finally what is the voltage at on the VCC and GND pads on the lcd board?
Yes, yes, and yes. Voltage is 2.55 on the LCD board between VCC and GND. I did run the wire between the GND on the controller PCB and the 2nd pin on the 8 pin as well.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2815
Joined: Thu May 05, 2016 8:33 am
Location: Rogers, AR
Has thanked: 1424 times
Been thanked: 3082 times

Re: Black Screen then White Screen

Post by Helder » Fri Aug 04, 2017 7:09 pm

Then there is your problem. It should be 3.28v or close to it. It might be a bad joint so reflow the pins on the 8pin connector and the first pin on the 18pin connector.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest