Sound card sorrows!

Having trouble with your mintyPi build? Post your questions here!
User avatar
Holydohnut
Posts: 194
Joined: Wed May 10, 2017 2:02 pm
Has thanked: 29 times
Been thanked: 68 times

Sound card sorrows!

Post by Holydohnut » Thu Aug 17, 2017 3:10 pm

Hey guys. Well, I finally gave up on my speakers ever arriving from China, and bought some from the UK. I've tried to solder it all up tonight and to make sure that each section still works, at the moment I've left the usb port attached. The Crystal and the headphone jack came off nice and easily with no pad damage, and to be honest, I wasnt expecting any issues. But sadly, when tested, the pi no longer sees the sound card. And it did before I messed.

Can anyone see anything obvious? I've checked all the new connectioms with a multimeter and they all seem fine. Or is it just that the sound cards are so nasty, that you can be as careful as you like, and still manage to destroy them?

Grateful for any help!
20170817_220349.jpg
20170817_220349.jpg (679.59 KiB) Viewed 2096 times
20170817_220425.jpg
20170817_220425.jpg (557.88 KiB) Viewed 2096 times
20170817_220340.jpg
20170817_220340.jpg (673.95 KiB) Viewed 2096 times

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2774
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1408 times
Been thanked: 3075 times

Re: Sound card sorrows!

Post by Helder » Thu Aug 17, 2017 3:14 pm

Got images of the back of the pcb?
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
Holydohnut
Posts: 194
Joined: Wed May 10, 2017 2:02 pm
Has thanked: 29 times
Been thanked: 68 times

Re: Sound card sorrows!

Post by Holydohnut » Thu Aug 17, 2017 3:57 pm

Sure!
20170817_225720.jpg
20170817_225720.jpg (645.18 KiB) Viewed 2089 times
Thanks for taking a look.

User avatar
Lphillimore
Posts: 984
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 784 times
Been thanked: 513 times

Re: Sound card sorrows!

Post by Lphillimore » Fri Aug 18, 2017 12:38 am

Can't see anything obvious as to why Pi wouldn't see it. For your own sanity and 'just incase' i would desolder it, freshly apply some solder to all required points, use fresh wire and retest.

Also check your USB pads incase any have lifted or come loose?

User avatar
Holydohnut
Posts: 194
Joined: Wed May 10, 2017 2:02 pm
Has thanked: 29 times
Been thanked: 68 times

Re: Sound card sorrows!

Post by Holydohnut » Fri Aug 18, 2017 3:50 am

Thanks. I'll give it a try when I get home. I suppose it is possible that the usb plug has come loose or something. It does only seem to be held on with a few tiny bits of solder.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2774
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1408 times
Been thanked: 3075 times

Re: Sound card sorrows!

Post by Helder » Fri Aug 18, 2017 3:54 am

Try testing continuity on the crystal too, test the crystal pin to these marked pins on the usb dac chip.
Image
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
tronicgr
Posts: 138
Joined: Tue Jun 07, 2016 4:26 pm
Has thanked: 94 times
Been thanked: 66 times
Contact:

Re: Sound card sorrows!

Post by tronicgr » Fri Aug 18, 2017 5:57 am

Doesnt look like this usb card has amplifier... wont play sound directly to a speaker!

Perhaps drawn too much current already and was burned...

User avatar
Holydohnut
Posts: 194
Joined: Wed May 10, 2017 2:02 pm
Has thanked: 29 times
Been thanked: 68 times

Re: Sound card sorrows!

Post by Holydohnut » Fri Aug 18, 2017 4:37 pm

Hi guys. I've just tested the traces from the crystal and, (using helders other pad trace photo) the connections on the usb and they all test fine.

I'm so confused! I don't know what could have caused this. It definitely worked when it first arrived!

Tronicgr -Are you aware that this is the exact card wermy uses in the mintypi build?

Abunchahicks
Posts: 52
Joined: Thu Jul 20, 2017 4:08 pm
Has thanked: 3 times
Been thanked: 11 times

Re: Sound card sorrows!

Post by Abunchahicks » Fri Aug 18, 2017 5:29 pm

What are the specs of the speaker (watts/ohms)? Also my first speaker didn't work even though my solder joints were good. There should be continuity through the speaker.

User avatar
rodocop
Posts: 1628
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 588 times
Been thanked: 578 times

Re: Sound card sorrows!

Post by rodocop » Fri Aug 18, 2017 5:36 pm

failed to attachShow
Image
Hey does your sound card give you this error? I'm having issues getting my sound card to work as well (No sound from speaker, I get this error above, i have continuity througb the speaker, and it worked with headphones before desoldering). It's a different card than yours. But I am having the same problems with two identical sound cards on two separate pi's. Once I'm back in town tomorrow I'll be able to do more troubleshooting.

I'm assuming it's an issue with my specific card (once I get the ones from the guide from China I'll try them.) But can't hurt to ask.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest