Using the TP4056 1 amp charger

Having trouble with your mintyPi build? Post your questions here!
dasfool
Posts: 17
Joined: Sat Aug 05, 2017 9:33 pm
Has thanked: 4 times
Been thanked: 5 times

Using the TP4056 1 amp charger

Post by dasfool » Mon Sep 11, 2017 7:07 pm

So I ordered the charger listed in the newest video (TP4056 https://www.amazon.com/gp/product/B01LZSC7I8/). I figure battery plus and minus go to the lipo battery. What I'm not sure of is where we wire Helder's board in. Any ideas?

User avatar
rodocop
Posts: 1226
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 490 times
Been thanked: 433 times

Re: Using the TP4056 1 amp charger

Post by rodocop » Mon Sep 11, 2017 8:09 pm

The bat + and - would also be wired to helders PCB I believe.

User avatar
Pentium
Posts: 74
Joined: Thu Jul 13, 2017 7:35 pm
Has thanked: 23 times
Been thanked: 8 times

Re: Using the TP4056 1 amp charger

Post by Pentium » Tue Sep 12, 2017 8:01 am

http://www.sudomod.com/forum/viewtopic.php?f=34&t=4036
scroll down, and there should be a crude diagram drawn by the ever so helpful dryja.

User avatar
dryja123
Posts: 1008
Joined: Tue May 09, 2017 5:34 pm
Location: Central NJ
Has thanked: 203 times
Been thanked: 527 times

Re: Using the TP4056 1 amp charger

Post by dryja123 » Tue Sep 12, 2017 8:46 am

Pentium wrote:
Tue Sep 12, 2017 8:01 am
http://www.sudomod.com/forum/viewtopic.php?f=34&t=4036
scroll down, and there should be a crude diagram drawn by the ever so helpful dryja.
I love that I'm finally developing a reputation for providing crude diagrams and being helpful :lol:

User avatar
Lphillimore
Posts: 968
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 749 times
Been thanked: 493 times

Re: Using the TP4056 1 amp charger

Post by Lphillimore » Tue Sep 12, 2017 5:10 pm

Depends if you're using Helders new Safe Shutdown board or not.

Either way, you're correct in where the battery is attached. B+ and B-.

As for the Out + and Out - it's as follows:

Out +
Goes to middle pin on power switch. The rightmost pin on power switch then goes to VCC of the button PCB.. OR.. Batt + if using the safe shutdown board. (Either will work).

Out -
Goes to GND pad on button PCB...OR... if you're using a safe shutdown board it goes to the Bat - or GND pad. (Either will work).

See generic 4056 image and one of Helders images below.

Pretty straight forward 😎
20170913_070352.png
20170913_070352.png (1014.81 KiB) Viewed 1504 times
Low_Battery_Monitor_board.jpg
Low_Battery_Monitor_board.jpg (272.25 KiB) Viewed 1504 times

User avatar
dryja123
Posts: 1008
Joined: Tue May 09, 2017 5:34 pm
Location: Central NJ
Has thanked: 203 times
Been thanked: 527 times

Re: Using the TP4056 1 amp charger

Post by dryja123 » Tue Sep 12, 2017 5:45 pm

The charger Wermy linked in his latest update has different connections from the picture you provided.

My crude drawing was based on this:
sku_373990_1.jpg
sku_373990_1.jpg (50.66 KiB) Viewed 1496 times

User avatar
Lphillimore
Posts: 968
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 749 times
Been thanked: 493 times

Re: Using the TP4056 1 amp charger

Post by Lphillimore » Tue Sep 12, 2017 7:03 pm

dryja123 wrote:
Tue Sep 12, 2017 5:45 pm
The charger Wermy linked in his latest update has different connections from the picture you provided.

My crude drawing was based on this:

sku_373990_1.jpg
Good call - mine is the slightly newer one with the protection circuit. Your drawing looks correct :D

dasfool
Posts: 17
Joined: Sat Aug 05, 2017 9:33 pm
Has thanked: 4 times
Been thanked: 5 times

Re: Using the TP4056 1 amp charger

Post by dasfool » Tue Sep 12, 2017 8:20 pm

Thanks for the replies everyone (and crude drawings!). I should be able to get things working from that. Any reason why wermy suggested the unprotected ones? The cost is pretty similar. The size is a bit different though.

User avatar
rodocop
Posts: 1226
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 490 times
Been thanked: 433 times

Re: Using the TP4056 1 amp charger

Post by rodocop » Tue Sep 12, 2017 8:35 pm

dasfool wrote:
Tue Sep 12, 2017 8:20 pm
Thanks for the replies everyone (and crude drawings!). I should be able to get things working from that. Any reason why wermy suggested the unprotected ones? The cost is pretty similar. The size is a bit different though.
I think most batteries have built in protection, so you don't necessarily need it in the board? I personally bought the protected ones. Little more money. But still really cheap.

Tonyclnsin
Posts: 2
Joined: Thu Mar 15, 2018 9:10 pm

Re: Using the TP4056 1 amp charger

Post by Tonyclnsin » Sun Apr 08, 2018 1:00 pm

I have this same tp4056 charger and I’m trying to connect it to helders aio board but I’m not sure how. Can someone please help me :(

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests