Screen completely black on first boot.

Having trouble with your mintyPi build? Post your questions here!
Post Reply
IronParzival
Posts: 5
Joined: Wed Apr 04, 2018 12:54 pm

Screen completely black on first boot.

Post by IronParzival » Wed Apr 04, 2018 1:36 pm

I am working on my MintyPi build and am having trouble getting video output.
I have the newest parts, started assembling them, and wanted to test them before I put them in the tin.

I have the correct power supply, all the test pads have continuity, the screen has a good ribbon connection, and I have reimaged the micro SD more times than I can count. The Pi shows activity, but no out put to screen.

Pictures of my setup are below attached.
(Note: the X, RST, and SDA are hard wired because the solder was refusing to show continuity between the test pads and GPIO pinholes)

If anyone has any ideas to get the screen to work, I would appreciate it.

Thank You,
IronParzival
Attachments
Setup4.jpg
Setup4.jpg (2.66 MiB) Viewed 748 times
Setup3.jpg
Setup3.jpg (2.31 MiB) Viewed 748 times

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2333
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1230 times
Been thanked: 2865 times

Re: Screen completely black on first boot.

Post by Helder » Thu Apr 05, 2018 3:34 am

It takes about 40 seconds to booth and light the LCD up, are you waiting long enough? Do you have 3.3v at the LCD test pad VCC? Does GND have good continuity from the Pi to the LCD board GND pad?
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

IronParzival
Posts: 5
Joined: Wed Apr 04, 2018 12:54 pm

Re: Screen completely black on first boot.

Post by IronParzival » Thu Apr 05, 2018 8:17 am

I’ve tested the voltage, I am getting 0V between 3.3V (board) and Vcc (LCD). I am getting 0V between both GNDs. For some reason I am getting 3.3V from Vcc (LCD) to GND on the board.

I have also tried to get output from HDMI, but the screen stays on “no input”

Edit: I have waited longer than 40 seconds.

Thanks for your response.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2333
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1230 times
Been thanked: 2865 times

Re: Screen completely black on first boot.

Post by Helder » Thu Apr 05, 2018 3:23 pm

So if you are getting 0V on the LCD then that tells me there is no power to the LCD so it won't light up, I think you have the reading wrong as if you have 3.3v on the GND then you have a short to power and could have potentially killed the LCD and or Pi.

It's like putting in a battery backwards, shit is going to fry unless you are doing the readings wrong and confusing continuity and voltage? Are you sure you know how to use a multimeter?
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

IronParzival
Posts: 5
Joined: Wed Apr 04, 2018 12:54 pm

Re: Screen completely black on first boot.

Post by IronParzival » Fri Apr 06, 2018 8:27 am

Is there any way to test if I fried the LCD?

I am not getting any video output at all (even from the HDMI)

Thanks

Griffindor6950
Posts: 1
Joined: Fri Apr 06, 2018 2:14 pm

Re: Screen completely black on first boot.

Post by Griffindor6950 » Fri Apr 06, 2018 2:33 pm

I'm having the same problem. I've looked through all the forums for similar issues and tested all the connections for voltage and continuity multiple times. Everything seems to be fine except for the screen. I've attached images of what I have so far. I'm looking for any help I can get.
Attachments
20180406_132521[1].jpg
20180406_132521[1].jpg (4.74 MiB) Viewed 665 times
20180406_132556[1].jpg
20180406_132556[1].jpg (4.16 MiB) Viewed 665 times
20180406_132743[1].jpg
20180406_132743[1].jpg (3.88 MiB) Viewed 665 times

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2333
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1230 times
Been thanked: 2865 times

Re: Screen completely black on first boot.

Post by Helder » Sun Apr 08, 2018 9:58 am

Griffindor6950 do you have 3.3v at the VCC and GND pads on the lcd board? Often times the 5V or 3.3v GPIO isn't fully making contact so check continuity for those and especially GND since it take excessive heat to really make a bond between boards (pi and controller pcb).

Check any and all power gpio and board pads against GND, you guys might have a GND to one of the connections that are required to power the screen or even maybe the power rail of the pi (notice 5v and GND are right next to each other).

If it's an GND issue meaning there is bad continuity for GND on the LCD board you can try any of these GND GPIOs to get GND to the controller pcb and lcd pcb.
Attachments
20180406_132743[1].jpg
20180406_132743[1].jpg (2.48 MiB) Viewed 638 times
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

IronParzival
Posts: 5
Joined: Wed Apr 04, 2018 12:54 pm

Re: Screen completely black on first boot.

Post by IronParzival » Sat Apr 14, 2018 10:49 am

Ok, I think I have the issue pinned down, I broke my ribbon cable. I can wiggle the cable to get a faint backlight and /or menu. But the position is very specific and I was not able to replicate it for a photo. 2 people have seen the backlight and menus.

Is the cable standard, or will we need one from you?
Attachments
1C600C2E-1354-46E3-B019-03D372036D87.jpeg
1C600C2E-1354-46E3-B019-03D372036D87.jpeg (1.72 MiB) Viewed 573 times

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2333
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1230 times
Been thanked: 2865 times

Re: Screen completely black on first boot.

Post by Helder » Sat Apr 14, 2018 1:38 pm

Not standard unless you search ebay or aliexpress for 10pin 1mm pitch 40mm long ribbon. I can always send you one just send me a PM about it with your shipping info.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

IronParzival
Posts: 5
Joined: Wed Apr 04, 2018 12:54 pm

Re: Screen completely black on first boot.

Post by IronParzival » Sat Apr 14, 2018 4:28 pm

Thanks, I’ll send you a message.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest