White Screen

Having trouble with your mintyPi build? Post your questions here!
Post Reply
kryan
Posts: 10
Joined: Thu Jul 27, 2017 7:37 pm
Has thanked: 1 time

White Screen

Post by kryan » Sat Jun 02, 2018 10:52 am

Good day All,

Ran into the white screen issue with my mintyPi (v2.0 board, stock mintyPi image). This was after a couple of weeks use with no issues. During gameplay the screen suddenly cut to white. I still got sound and was able to use the hotkey to safely shut down the system. Each time I restarted the system afterwards, it would always cut to white at some point between the Retropie logo and the mintyPi splash screen. Sound still plays and the hotkeys still worked, so the system is booting up fully.

Here's what I've tried so far:
  • Hooked it up to HDMI. Everything seems to function normally.
  • Tested continuity between the Pi and the PCB. All okay.
  • Tested continuity between the PCB and the LCD screen board. All okay.
  • Tested continuity between the Pi and the LCD screen board. All okay.
  • Checked voltage across the LCD screen's VCC and GND. I'm getting 3.28V while running off of the battery.
  • Swapped the ribbon cable with a new one. No change.
Here's a picture of the soldering for reference:
SpoilerShow
20180602_123434.jpg
20180602_123434.jpg (1.15 MiB) Viewed 333 times
The only other recommended solution I've come across was to add solder to the ribbon connector pins on the PCB and LCD screen. This was a daunting project for my first soldering job. Before I break out the iron again, is there anything else I can try to resolve the issue?

Any feedback would be appreciated. Thanks.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2333
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1231 times
Been thanked: 2865 times

Re: White Screen

Post by Helder » Sat Jun 02, 2018 1:35 pm

check the lcd ribbon itself for damage or maybe a weak solder joint, the addition of some extra solder to the ribbon connector socket pins is a good thing to try too.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

kryan
Posts: 10
Joined: Thu Jul 27, 2017 7:37 pm
Has thanked: 1 time

Re: White Screen

Post by kryan » Sat Jun 02, 2018 5:26 pm

Hey Helder. Thanks for the quick reply.

After adding more solder to the screen and PCB ribbon connector pins, and swapping out the old ribbon cable with a spare, the screen got all the way to the emulation station menu before cutting out to white again.

I swapped the screen with a brand new one from a second mintyPi kit and it seems to be holding out with no issue, so the problem may lie with the original screen.

Here's a picture of the original screen's connectors for reference:
SpoilerShow
20180602_191357.jpg
20180602_191357.jpg (1.04 MiB) Viewed 322 times
Just to clarify, should the solder be added to the 18 pin ribbon, or the 10 pin connector?

Thanks again.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2333
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1231 times
Been thanked: 2865 times

Re: White Screen

Post by Helder » Mon Jun 04, 2018 2:26 am

10 pin connector, the 18pin looks fine but doesn't hurt to reflow it.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests