Audio is way too low

General GBZ-related chat goes here. Share ideas, tips and tricks, or ask questions that don't fit into the hardware/software help forums.
Zacarycaine
Posts: 20
Joined: Wed Sep 28, 2016 6:16 pm

Audio is way too low

Post by Zacarycaine » Sat Nov 26, 2016 1:07 am

So I was finally able to test my audio and it seems to be working but its WAY too low.

I'll turn the volume wheel all the way up and you can barely hear it.

The fact that sounds is coming out means my wiring is correct, right?

So what could be the issue?

User avatar
ABH
Posts: 188
Joined: Sat May 28, 2016 7:01 pm
Location: Qatar
Has thanked: 80 times
Been thanked: 112 times

Re: Audio is way too low

Post by ABH » Sat Nov 26, 2016 1:22 am

Try to turn up Retropie volume to 100% in the settings menu

start > sound settings

Zacarycaine
Posts: 20
Joined: Wed Sep 28, 2016 6:16 pm

Re: Audio is way too low

Post by Zacarycaine » Sat Nov 26, 2016 2:23 am

Eh, that worked thank you.

However, the audio is still really low.

Jace055
Posts: 32
Joined: Tue Sep 27, 2016 10:01 pm
Has thanked: 2 times
Been thanked: 12 times

Re: Audio is way too low

Post by Jace055 » Sat Nov 26, 2016 10:00 am

There are 4 separate volume controls.

1. Your physical volume pot
2. RetroPie volume
3. AlsaMixer
4. RetroArch (hold select and press your x button to bring up the menu in game)

Have you turned all 4 up?

Zacarycaine
Posts: 20
Joined: Wed Sep 28, 2016 6:16 pm

Re: Audio is way too low

Post by Zacarycaine » Sat Nov 26, 2016 1:34 pm

Jace055 wrote:There are 4 separate volume controls.

1. Your physical volume pot
2. RetroPie volume
3. AlsaMixer
4. RetroArch (hold select and press your x button to bring up the menu in game)

Have you turned all 4 up?
1. Got it.
2. Got it.
3. What is AlsaMixer? Never heard of it, can you please explain and explain how I can turn it up?
4. I will also try this later today!

Thank you.

Jace055
Posts: 32
Joined: Tue Sep 27, 2016 10:01 pm
Has thanked: 2 times
Been thanked: 12 times

Re: Audio is way too low

Post by Jace055 » Sat Nov 26, 2016 3:23 pm

Check here. https://learn.adafruit.com/adding-basic ... -pwm-audio

This community uses option #1 and you can skip the bulk of the write up, if your speaker is working, down to the "adjusting volume" section.

Edit: I just realized there is a section after that to automate what they are trying to do. We don't need that. I wanted to be clear, you only need to ssh into your pi and run alsamixer in the terminal and press up until you see 100% at the bottom.

Zacarycaine
Posts: 20
Joined: Wed Sep 28, 2016 6:16 pm

Re: Audio is way too low

Post by Zacarycaine » Sun Nov 27, 2016 12:16 am

Jace055 wrote:Check here. https://learn.adafruit.com/adding-basic ... -pwm-audio

This community uses option #1 and you can skip the bulk of the write up, if your speaker is working, down to the "adjusting volume" section.

Edit: I just realized there is a section after that to automate what they are trying to do. We don't need that. I wanted to be clear, you only need to ssh into your pi and run alsamixer in the terminal and press up until you see 100% at the bottom.
Okay I got Alsamixer at 100%
It looked like it was already at 100% when i got there so Im good.

I accesed Retro Arch and went into Settings>Audio>Audio Volume Level and turned it all the way up to 12.

I go back to the main menu and press "Save new Config"

But then when i exit out of Retro Arch and go back in to see if my settings were the same.

They are not. The audio level is reset to 0.

How do I keep it from resetting?

Jace055
Posts: 32
Joined: Tue Sep 27, 2016 10:01 pm
Has thanked: 2 times
Been thanked: 12 times

Re: Audio is way too low

Post by Jace055 » Sun Nov 27, 2016 6:03 am

There is an option to save on RetroArch exit that need to be turned on. I can check tonight if you haven't found it by then. You need to turn the volume to 12 and save on exit for each one of your emulators.

PIXeL_92
Posts: 116
Joined: Thu Sep 15, 2016 3:53 pm
Location: 127.0.0.1 (UK)
Has thanked: 11 times
Been thanked: 28 times

Re: Audio is way too low

Post by PIXeL_92 » Sun Nov 27, 2016 7:47 am

Hope you don't mind the thread jacking I am also having the same issue sounds works but is so Ooo quiet. Tried all of the above apart from the retroarch bit will try later and confirm if it has fixed it.
Needs parts for your Gameboy Zero or even just normal Gamboy mods, head over to http://www.deadpanrobot.co.uk/ and use the discount code RGREPAIRS for a 10% discount code. Loads of great products at affordable prices.

Instagram - http://instagram.com/robsgamerepairs

Zacarycaine
Posts: 20
Joined: Wed Sep 28, 2016 6:16 pm

Re: Audio is way too low

Post by Zacarycaine » Sun Nov 27, 2016 3:58 pm

Jace055 wrote:There is an option to save on RetroArch exit that need to be turned on. I can check tonight if you haven't found it by then. You need to turn the volume to 12 and save on exit for each one of your emulators.
I was looking around for a while and couldn't find it.

Were you able to?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest