LPs First GBZ

Show off your completed Game Boy Zero, or post your build logs here!
User avatar
Lphillimore
Posts: 989
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 791 times
Been thanked: 516 times

LPs First GBZ

Post by Lphillimore » Mon Feb 06, 2017 6:33 pm

At long last I've finally completed my first build.

Had a delay after my Gearbest screen died on just before completion. New BW screen from Amazon UK arrived yesterday (I now live in Perth, Australia).

Albeit a few tweaks still to make before I'm completely happy.
20170208_072211.png
20170208_072211.png (729.75 KiB) Viewed 3325 times
Here's the front and back:

Front:
SpoilerShow
20170206_233634.jpg
20170206_233634.jpg (3.97 MiB) Viewed 6203 times
Back:
SpoilerShow
20170205_154316.jpg
20170205_154316.jpg (3.68 MiB) Viewed 6203 times
Had some trouble closing the case despite trimming the wires as much as I could. All closed up now but perhaps a bit too much pressure on the screen as hard button presses or case presses cause the screen to distort, like if you press your finger on a screen too hard.

Will look to fix this.

Also to fix:

- Space inside battery bay - had to sacrifice my 2nd USB port as I couldn't fit this and the battery. Will look to reinstate.

- USB port on side isn't quite straight.

- Going to use white silicone to fill surround of USB charge port.

- Audio - headphones work perfectly, speaker suffering from AIO 2.2 issues noted across forum. If volume is slightly increased the sound it intermittent and broken etc. Noted fix from others regarding 2x 75ohm resistors.

- Align the mini HDMI output slightly better as its not quite straight with case opening.


All in all, happy with the look!

Lots learned on this one, from doing little to no soldering before (Year 7 school project with a 9v battery and a red LED only) to being confident on the iron and soldering with speed and accuracy.

100% recommend the temperature controlled iron and 3rd hand.

Thanks to everyone who helped with my queries to date and special thanks to @wermy and @helder.
Last edited by Lphillimore on Tue Jul 18, 2017 9:46 am, edited 2 times in total.

Thommy86
Posts: 2
Joined: Thu Jul 14, 2016 7:43 am
Has thanked: 1 time
Been thanked: 1 time

Re: LPs First GBZ

Post by Thommy86 » Tue Feb 07, 2017 3:18 am

Instead of silicone you could use Sugru. I don't have a great picture, but you can see belowe how is smoothen the hdmi connectors.

I thought I would share, as I was really glad I found this solution.

https://www.mupload.nl/img/znajfy5t9wrkp.13.51.jpeg

User avatar
Lphillimore
Posts: 989
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 791 times
Been thanked: 516 times

Re: LPs First GBZ

Post by Lphillimore » Tue Feb 07, 2017 4:08 am

Nice one, thanks.

This looks better than silicone. Will look into getting some!

UPDATE:

Arrived and applied, very happy with it!

Also filled in the micro HDMI out as i wont use it and i never quite got it aligned.

Thanks again @Thommy86
SUGRU.PNG
SUGRU.PNG (1.55 MiB) Viewed 5855 times
Last edited by Lphillimore on Mon Feb 13, 2017 7:04 am, edited 1 time in total.

User avatar
Lphillimore
Posts: 989
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 791 times
Been thanked: 516 times

Re: LPs First GBZ

Post by Lphillimore » Tue Feb 07, 2017 4:26 pm

Update on fixes:

- Space inside battery bay - had to sacrifice my 2nd USB port as I couldn't fit this and the battery. Will look to reinstate.

2nd USB re-added. Trimmed some more excess wire and re-soldered. Tested working. Battery now fits.

- USB port on side isn't quite straight.

Fixed

- Going to use white silicone to fill surround of USB charge port.

Ordered some Sugru. Thanks @Thommy86

- Audio - headphones work perfectly, speaker suffering from AIO 2.2 issues noted across forum. If volume is slightly increased the sound it intermittent and broken etc. Noted fix from others regarding 2x 75ohm resistors.

- Added the 75ohm resistors as advised by @helder and setup by @Tomatoflames - All now working perfectly. THANKYOU

- Align the mini HDMI output slightly better as its not quite straight with case opening.

Made some adjustments but not perfect, more work to be done.

Extra work carried out:

Added the custom theme created by @RxBrad - this improves the display and look massively! Thanks.
20170208_072211.png
20170208_072211.png (729.75 KiB) Viewed 6086 times
Custom splash screen also added, courtesy of @AJRedfern This is awesome.

Still to be done:

1) Wi-Fi still not working. No Wi-Fi networks detected when USB 2.0 is enabled and USB WiFi plugged in. Enabling USB 1.1 caused interference on the screen and random behaviour of controls. Still unable to find WiFi network. Will keep investigating.

User avatar
Pirate
Posts: 137
Joined: Thu Oct 13, 2016 8:54 pm
Has thanked: 95 times
Been thanked: 54 times

Re: LPs First GBZ

Post by Pirate » Fri Feb 10, 2017 9:12 pm

on my first build the USB ports weren't working and found out why
the reason was because I was using wires that were too thick

User avatar
AJRedfern
Posts: 85
Joined: Wed Sep 07, 2016 4:29 am
Has thanked: 53 times
Been thanked: 54 times
Contact:

Re: LPs First GBZ

Post by AJRedfern » Sat Feb 11, 2017 1:08 am

Very nice looking build!

Happy to hear that you are using the splash screen and that you like it.
AJRedfern - Author of the Game Boy Zero Splash Screen seen in Wermy's Custom Parts Guide Pt 2.
Image
http://www.sudomod.com/forum/viewtopic.php?f=8&t=1440

User avatar
silentjames
Posts: 98
Joined: Fri Jan 27, 2017 9:02 am
Location: Russia
Has thanked: 35 times
Been thanked: 32 times

Re: LPs First GBZ

Post by silentjames » Sat Feb 11, 2017 5:26 am

Awesome build! Going to create my own with white shell and red/green/blue/yellow buttons too. Where did you find them? From SNES controller?

User avatar
Lphillimore
Posts: 989
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 791 times
Been thanked: 516 times

Re: LPs First GBZ

Post by Lphillimore » Sun Feb 12, 2017 4:25 am

@silentjames Yeah from a USB SNES pad i had lying about. I really wanted official SNES buttons but cant face breaking one and cant seem to find any online listed as 'not working'.

I have another USB SNES pad but i find they vary so much and the buttons on that one look terrible.

Have ordered another one online but often the pictures vs what you receive vary too. Hoping for a decent one i can use for my next build.

User avatar
Lphillimore
Posts: 989
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 791 times
Been thanked: 516 times

Re: LPs First GBZ

Post by Lphillimore » Sun Feb 12, 2017 4:27 am

@AJRedfern Thanks, pretty happy with it overall.

The splashscreen added that bit extra extra 8-)

Great work.

What did you use to create it? Might have a go myself.

User avatar
Lphillimore
Posts: 989
Joined: Sat Jan 07, 2017 7:03 pm
Location: Perth, WA
Has thanked: 791 times
Been thanked: 516 times

Re: LPs First GBZ

Post by Lphillimore » Sun Feb 12, 2017 4:32 am

@pirate Cheers for the tip. Have since rewired a bit and USBs work fine on 2.0 or 1.1(no interference etc). Still no joy with WiFi however. Might be the USB dongle I'm using although i have had it connected before as it managed to see the network. Also works on other pi's. Changed the audio to mono, too as per advice from @144TECH.

No joy yet so used my sdcard in my Pi3 to transfer roms, setup themes, scrape etc.

Still investigating WiFi :P :idea:

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest