Kite Circuit Sword Screen Issues

Having trouble with your GBZ build? Ask your questions here!
Post Reply
User avatar
lord_of_misrule
Posts: 23
Joined: Thu Jan 31, 2019 7:44 pm
Been thanked: 4 times

Kite Circuit Sword Screen Issues

Post by lord_of_misrule » Mon Feb 03, 2020 7:16 pm

Hey everyone! So I recently got my my board back from Kite (it wouldn't hold a charge & he fixed it); the battery now charges, however I can't close up the case without the screen glowing bright white. The screen has just been sitting, ribbon up, for months waiting for the board to be returned. It's the weirdest thing: if I hold it away from the board, it appears normal. I can even rest the top half of the case on the bottom and it's fine, but as soon as I lower it into place to close it up, the screen goes white :cry: See below:

https://youtu.be/gSHmegO-gpw

Any thoughts? It would be much appreciated :mrgreen:

_misrule_

User avatar
rodocop
Posts: 1647
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 597 times
Been thanked: 587 times

Re: Kite Circuit Sword Screen Issues

Post by rodocop » Tue Feb 04, 2020 10:50 am

Maybe the screen is touching something when closed? I would start by putting a layer of kapton tape on the back of the screen to prevent anything touching it. (Or on the PCB itself)

Could also look at covering the LCD ribbon connector as well.

It's really strange. But that would be my first step. Worst case contact kite again.

User avatar
lord_of_misrule
Posts: 23
Joined: Thu Jan 31, 2019 7:44 pm
Been thanked: 4 times

Re: Kite Circuit Sword Screen Issues

Post by lord_of_misrule » Tue Feb 04, 2020 12:29 pm

Thanks rodo,

I THOUGHT that might be an issue, so I covered the back of the screen with kapton tape and even on the board under the ribbon.

I'll look into covering the ribbon tonight when I get home. Hopefully that works, if not then I guess I'll be contacting Kite again :P

User avatar
kite
Posts: 932
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 237 times
Been thanked: 313 times
Contact:

Re: Kite Circuit Sword Screen Issues

Post by kite » Wed Feb 05, 2020 7:28 am

Could you show it with the TESTER mode thing where it shows the colour bars, ideally getting a picture of the bars with it looking 'normal' and then 'bright'?

User avatar
lord_of_misrule
Posts: 23
Joined: Thu Jan 31, 2019 7:44 pm
Been thanked: 4 times

Re: Kite Circuit Sword Screen Issues

Post by lord_of_misrule » Sat Feb 08, 2020 12:11 pm

kite wrote:
Wed Feb 05, 2020 7:28 am
Could you show it with the TESTER mode thing where it shows the colour bars, ideally getting a picture of the bars with it looking 'normal' and then 'bright'?
https://youtu.be/Qofe304LId8

Hope this helps

User avatar
kite
Posts: 932
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 237 times
Been thanked: 313 times
Contact:

Re: Kite Circuit Sword Screen Issues

Post by kite » Tue Feb 18, 2020 1:49 am

Ok cool, well i'm a bit stumped to be honest, it's either going to be the LCD or the main board, and I can't imagine what the main board would be doing to cause that, so I'm going to assume it's the LCD.. could you send me an email with your address, and I'll get a replacement LCD sent to you

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest