OneForAll (Helder) Input Woes

Having trouble with your GBZ build? Ask your questions here!
Post Reply
User avatar
GigaCat
Posts: 34
Joined: Wed Jun 19, 2019 1:21 pm
Location: Phoenix, AZ
Has thanked: 18 times
Been thanked: 15 times

OneForAll (Helder) Input Woes

Post by GigaCat » Mon Sep 23, 2019 1:31 pm

So I have Helder's OneForAll installed on my GBZ w/RetroPSU, wired and configured almost precisely as illustrated in the Github readme (save for pins 13 and 18, which I moved elsewhere in favor of PWM audio). Image installed is the latest RetroPie 4.5.1 Pi0/1 build, no package updates (yet). All buttons work. The analog stick works. Everything works.

...in EmulationStation.

I select a game, it loads, and then it's like the input autoconfig never kicked in, because there is no button response at all in RetroArch. The Mode button still works, and I can still change OneForAll settings, but I can't even exit the game unless I either dirty shutoff or kill via SSH. I tried this in gamepad mode and keyboard mode (analog stick enabled/disabled) and got the same result each time.

That said, I added (Helder) to the thread title because I was reading through the Github Issues page and learned that user withgallantry updated OneForAll just about a month ago. I'm going to test that when I get home, which might just turn this thread into a problem/solution talkthrough, but has anyone had better luck with the updated script?

User avatar
VeteranGamer
Posts: 1703
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 498 times
Been thanked: 883 times

Re: OneForAll (Helder) Input Woes

Post by VeteranGamer » Tue Sep 24, 2019 2:28 am

your not the only one that's experience this....
I've got this on one of the build i need to complete, just haven't got around to resolve it.....

I haven't tried the other script (it may fix this)....
but the install instructions seem a little vague (to me anyway)

Helder does mention that Bluup may/should/will be updating the scrip soon....
viewtopic.php?f=38&t=6421&start=150#p77733

Bluup would be the best person to answer or provide a resolution to this...



.

User avatar
infinitLoop
Posts: 381
Joined: Mon Dec 24, 2018 11:46 am
Has thanked: 162 times
Been thanked: 129 times
Contact:

Re: OneForAll (Helder) Input Woes

Post by infinitLoop » Tue Sep 24, 2019 9:02 am

something that has worked for me, at least for the exiting ROMs part, is to use Retrogame to map the controls - it lets you do one key-combo mapping, so i always map the ESC key to a combination of whatever pins i used for Start and Select. you just map that as your last key, like...

SPACE 5 #select
ENTER 12 #start
ESC 12 5 #start+select

You just have to hold the buttons for a couple seconds to activate that alt-key. Esc should exit retroarch (as well as some other screens).

you could also try messing with the config file, to set the button mappings manually, in the /opt/retropie/configs/{emulator}/retroarch.cfg file

User avatar
GigaCat
Posts: 34
Joined: Wed Jun 19, 2019 1:21 pm
Location: Phoenix, AZ
Has thanked: 18 times
Been thanked: 15 times

Re: OneForAll (Helder) Input Woes

Post by GigaCat » Wed Sep 25, 2019 9:40 am

Weird story time:

- Since both versions run the same folder name, I renamed the original OneForAll 'OneForAll2', commented out the run command in rc.local, and added my own line to run the new script. It worked almost identically to the first... right down to it not responding in RetroArch. GPIO setup was intuitive enough.

- A day later, my system suddenly stopped reading monitor.py (never quite recorded the error message). Went back to loading the original program by changing the rc.local command to load from my OneForAll2 folder. Reset ES input config in RetroPie-Setup and did it all again in Gamepad Mode (analog stick enabled and on by default in keys.cfg).

Literally everything works now. How?

Aside from moving the original to another folder, editing rc.local a little, and redoing all GPIO connections with new wire (which turned into a few repositioned buttons), I can't quite put my finger on what fixed it.

User avatar
VeteranGamer
Posts: 1703
Joined: Thu Jan 26, 2017 11:12 am
Location: London, UK
Has thanked: 498 times
Been thanked: 883 times

Re: OneForAll (Helder) Input Woes

Post by VeteranGamer » Wed Sep 25, 2019 11:30 am

GigaCat wrote:
Wed Sep 25, 2019 9:40 am
Reset ES input config in RetroPie-Setup and did it all again in Gamepad Mode (analog stick enabled and on by default in keys.cfg).
I've been communicating Bluup on Discord...

he has advised that once you install Helder/OneForAll
you have/need to reconfigure the controls in emulation station...

this should resolve these issue....


I personally haven't had a chance to do this yet.....




.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2789
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1412 times
Been thanked: 3077 times

Re: OneForAll (Helder) Input Woes

Post by Helder » Tue Oct 01, 2019 6:42 pm

I think in my version of the script which is now outdated you need to configure the controls in Emulation Station when in gamepad mode then in keyboard mode.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest