Circuit Sword Lite - Headphone Jack - No sound! HELP!

Having trouble with your GBZ build? Ask your questions here!
Post Reply
jaimz
Posts: 7
Joined: Tue May 19, 2020 1:45 pm
Has thanked: 3 times

Circuit Sword Lite - Headphone Jack - No sound! HELP!

Post by jaimz » Sun Jun 14, 2020 5:57 pm

Hi everyone,

It was going so good.

I finished my build today after a 6 hour stint and was lucky to enjoy a few hours of old school gaming, until I tried using headphones.

My build has a Circuit Sword Lite and everything worked fine, including the sound. However, I found the headphone jack to be stiff when inserting and removing headphones but I didn't think too much of it since it's a custom build.

After playing through the speaker, I decided to plug the headphones in and found that they wouldn't go in all the way (stiffness) and the sound was still coming through the speaker. I knew there was still some of the headphone jack left to be inserted, so I pushed them in further and I felt something dislodge and started noticing the sound was distorting. Not too long after that the sound stopped working entirely. Now the sound doesn't work when I use either the speaker or the headphones.

I dis-assembled the case and it looked like the DAC and AMP sections on the headphone jack on the board had come dislodged on the left hand side. Since the right side contact points had solder on them, I decided to try and solder the two points that became dislodged back. Unfortunately, the solder didn't seem to stick to the points back to the board and the sound still doesn't work. I wish I'd left it alone and not tried to solder it back. I genuinely feel like I've ruined this entire build now and I've only had it for a few hours.

Can anyone tell me if it's salvageable or should I just give up on it now? These builds aren't cheap and I feel pretty gutted that something as silly as a stiff headphone jack has potentially cost me a few hundred pounds. I don't feel confident soldering parts that were already soldered on Kite's board without any help or instruction from someone maybe more experienced with electronics.

Picture below of the board in question:

https://imgur.com/gallery/qYHsTC6

Any help is massively appreciated. Thank you all.

James

jaimz
Posts: 7
Joined: Tue May 19, 2020 1:45 pm
Has thanked: 3 times

Re: Circuit Sword Lite - Headphone Jack - No sound! HELP!

Post by jaimz » Wed Jun 17, 2020 5:56 am

Nobody else had this issue before?

If I can’t repair the headphone jack I think that’s this build out of the window which is disappointing 👎🏻

User avatar
infinitLoop
Posts: 532
Joined: Mon Dec 24, 2018 11:46 am
Location: Portland, OR
Has thanked: 220 times
Been thanked: 193 times
Contact:

Re: Circuit Sword Lite - Headphone Jack - No sound! HELP!

Post by infinitLoop » Wed Jun 17, 2020 11:24 am

try posting in kite's forum. it sounds like you lifted the traces off the board when you knocked the jack off, so you won't be able to just solder it back in place. you'll need to expose some more of the trace, or solder a wire/jumper to whereever those were going. but if you ask in his support forum, you'll probably get more accurate advice.

https://www.sudomod.com/forum/viewforum.php?f=51


.

jaimz
Posts: 7
Joined: Tue May 19, 2020 1:45 pm
Has thanked: 3 times

Re: Circuit Sword Lite - Headphone Jack - No sound! HELP!

Post by jaimz » Thu Jun 18, 2020 11:46 am

Thank you for the reply! I'll post it to Kite's forum. I'm new to this so still working out where is best to post.

Thanks again!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest