Speaker really low and all I can hear is static.

Hardware-related questions that don't fit into any of the specialized hardware categories go here.
Post Reply
User avatar
firestw152
Posts: 79
Joined: Mon Mar 06, 2017 5:14 pm
Has thanked: 22 times
Been thanked: 3 times

Speaker really low and all I can hear is static.

Post by firestw152 » Wed Aug 02, 2017 8:44 pm

Hello, this is my set up right now. https://photos.google.com/share/AF1QipN ... swbG5sd0lR


I have the audio in the retropie menu set to 85 and my headphones sound fantastic with the filter. However the speakers sound really low and there is a ton of static. I can only hear the game if I hold my ear up to the speaker. Any suggestions?

This is what I put in my config.txt

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1
audio_pwm_mode=2


dtoverlay=pwm,pin=18,func=2



The PWM mode 2 is suppose to make it sound better without the need for a filter but I still need the filter.I honestly don't know if I have it turned on or not.

User avatar
tinkerBOY
Posts: 702
Joined: Tue May 30, 2017 4:00 am
Has thanked: 294 times
Been thanked: 200 times

Re: Speaker really low and all I can hear is static.

Post by tinkerBOY » Thu Aug 03, 2017 9:26 am

Already answered this on http://www.sudomod.com/forum/viewtopic. ... =20#p40123

On you picture, A- doesn't seem to be connected to anything. It should be connected to ground (GND).
New! tinkerBOY PowerSwitch v1.0 with Safe Shutdown
Game Boy Zero Controllers available @ tinkerBOY.xyz * Support
tinkerBOY Controller v3.0 - built-in usb controller, usb audio, and usb hub
tinkerBOY Controller v2.0 - GPIO buttons and builtin PWM Audio and Amplifier
tinkerBOY Controller v1.1 - simple pcb button
* DPI Adapter - better display for GBZ
* keyboard converters - IBM XT/AT Soarer's Converter | ADB to USB Converter

User avatar
firestw152
Posts: 79
Joined: Mon Mar 06, 2017 5:14 pm
Has thanked: 22 times
Been thanked: 3 times

Re: Speaker really low and all I can hear is static.

Post by firestw152 » Thu Aug 03, 2017 12:37 pm

zeroboy wrote:
Thu Aug 03, 2017 9:26 am
Already answered this on http://www.sudomod.com/forum/viewtopic. ... =20#p40123

On you picture, A- doesn't seem to be connected to anything. It should be connected to ground (GND).
Sorry zeroboy I saw your reply after I made the post and couldnt figure out how to delete it.


But I grounded the A- and nothing changed so I switched to this green amp and everything is working fine now with some slight static that I hope to fix by adding a 20 ohm resistor to the speaker.

https://photos.google.com/share/AF1QipO ... hIU0pRa1ZB


I tried 2 different adafruit amps and they didnt work but this cheap green one did. I have no idea why.

User avatar
rodocop
Posts: 1639
Joined: Mon Aug 22, 2016 3:14 pm
Location: Saskatchewan
Has thanked: 596 times
Been thanked: 582 times

Re: Speaker really low and all I can hear is static.

Post by rodocop » Wed Aug 23, 2017 4:15 pm

firestw152 wrote:
Thu Aug 03, 2017 12:37 pm
zeroboy wrote:
Thu Aug 03, 2017 9:26 am
Already answered this on http://www.sudomod.com/forum/viewtopic. ... =20#p40123

On you picture, A- doesn't seem to be connected to anything. It should be connected to ground (GND).
Sorry zeroboy I saw your reply after I made the post and couldnt figure out how to delete it.


But I grounded the A- and nothing changed so I switched to this green amp and everything is working fine now with some slight static that I hope to fix by adding a 20 ohm resistor to the speaker.

https://photos.google.com/share/AF1QipO ... hIU0pRa1ZB


I tried 2 different adafruit amps and they didnt work but this cheap green one did. I have no idea why.
Also, I notice your don't have a ground on your volume wheel, maybe add a ground wire to pin 1 on the wheel. It might help with the static. It's pretty much impossible to get rid of all static on PWM audio though.

another thing, those ada fruit amps have their own small built in pot that you can adjust with a screwdriver. Maybe it was adjusted too low...Either way, glad you got it working with the other amp.

kirestus
Posts: 33
Joined: Thu Nov 03, 2016 10:39 pm

Re: Speaker really low and all I can hear is static.

Post by kirestus » Thu Aug 24, 2017 2:19 am

i had this same issue while i was working on mine, i ran it to the ground strip where all the power connects to,

i thought that the issue was with my low pass filter when infact it was with the amp.

make sure you ground your lowpass filter also though,

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest