[Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Completed sale threads will be moved here to keep things tidy in the main For Sale forum.
User avatar
Helder
Trailblazer
Trailblazer
Posts: 2754
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1404 times
Been thanked: 3069 times

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by Helder » Fri Mar 03, 2017 12:37 pm

SumCanadianGuy wrote:
Treguard wrote:Sorry if this has already been asked, but is there a wiring diagram for this (assuming it'll be the same for v1.1 as v1.0?) using alongside Helders AIO 2.2 board?

Thanks in advance
I'd like to know this too. I Checked the whole thread and did a few in thread searches and didn't see anything. I have @Helders newest board, Powerboost 1000c, Pi Zero 1.2 and this switch.
A whole thread was made for this topic here a little while ago:
http://www.sudomod.com/forum/viewtopic.php?f=8&t=2286
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
SumCanadianGuy
Posts: 107
Joined: Mon Oct 03, 2016 11:37 am
Has thanked: 51 times
Been thanked: 19 times

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by SumCanadianGuy » Fri Mar 03, 2017 9:10 pm

Thank you so much! I searched like mad. Here, google, YouTube. Found nothing. Hoping to get mine finished up tonight.

User avatar
SumCanadianGuy
Posts: 107
Joined: Mon Oct 03, 2016 11:37 am
Has thanked: 51 times
Been thanked: 19 times

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by SumCanadianGuy » Sun Mar 05, 2017 11:30 am

Switch works great. Just had a quick question. Occasionally, not every time, when I flip the switch off while it's doing its shut down the screen flashes on and off. It hasn't seemed to effect anything adversely, just wondering if anyone else had seen this.


Added a video to help explain it

https://youtu.be/rU5LAe4X5hQ

User avatar
Camble
Posts: 879
Joined: Thu May 05, 2016 2:31 am
Location: Scotland
Has thanked: 269 times
Been thanked: 487 times

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by Camble » Sat Mar 11, 2017 1:55 am

@SumCanadianGuy That doesn't look like a safe shutdown issue. Not sure what could be causing that tbh.

User avatar
SumCanadianGuy
Posts: 107
Joined: Mon Oct 03, 2016 11:37 am
Has thanked: 51 times
Been thanked: 19 times

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by SumCanadianGuy » Sat Mar 11, 2017 7:25 am

Strange. It only happens when I use the switch so I thought it was related. If I do a shutdown via emulation station o let it do its 60 second shut down it doesn't do that. Maybe it's a power boost issue. My battery seems to take WAY to long to charge (it's a "4000mah" and has been charging for 8 hours and is still yellow) and only lasts about an hour.

User avatar
Camble
Posts: 879
Joined: Thu May 05, 2016 2:31 am
Location: Scotland
Has thanked: 269 times
Been thanked: 487 times

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by Camble » Sat Mar 11, 2017 7:48 am

@SumCanadianGuy Maybe a short somewhere?

garthster
Posts: 22
Joined: Mon Jan 15, 2018 11:40 pm
Has thanked: 1 time
Been thanked: 1 time

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by garthster » Mon Feb 19, 2018 1:50 pm

Ok, so I have my safe shutdown (cool little product) V1.2 powerboost.

Got it installed.

Starts the system like it should.

Wont shutdown when I turn the switch off.

If I leave the switch of and shutdown from software I get a kernal panic........

Turning the switch off turns off the powerboost at this point like it should.

Additionally I should point out that both the low battery warning and the startup arrest on low battery dont seem to be working.

When I run python ~/GBZ-Power-Monitor_PB/gbz_power_monitor.py the power monitor comes up and tries to shutdown my gameboy.......but fails. So the battery monitoring is working......

It seems like the power monitor is not running in the background like it should, and at this point I am rather stumped.
Attachments
0219181434_HDR.jpg
0219181434_HDR.jpg (2.43 MiB) Viewed 1926 times
0219181443.jpg
0219181443.jpg (2.87 MiB) Viewed 1926 times

User avatar
Camble
Posts: 879
Joined: Thu May 05, 2016 2:31 am
Location: Scotland
Has thanked: 269 times
Been thanked: 487 times

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by Camble » Mon Feb 19, 2018 2:07 pm

@garthster Thank you :) Your wiring to the Safe Shutdown looks fine. I can't be sure of the wiring to the PowerBoost, but you have good connections elsewhere so unless something is in the wrong place, I can't see it being wiring.

The reason you get a kernel panic when you shutdown through software (or indeed on low battery) is because the power switch is still in the On position. An unfortunate side effect that I was unable to eliminate.

Does it work if you remove the components from the case? Please check you haven't got a short anywhere else and remove then reinstall the script.

garthster
Posts: 22
Joined: Mon Jan 15, 2018 11:40 pm
Has thanked: 1 time
Been thanked: 1 time

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by garthster » Mon Feb 19, 2018 2:39 pm

Thanks for the prompt response.

Ok, I removed the switch and powerboost components from the case, still the same issue. My powerboost lines are wired properly like the pi.

How would I uninstall the power monitor script? Prolly a silly question, but I didn't seem to find instructions for that.

I suspect a software issue of some sort, as the hardware seems to be working as I would expect, but the pi does not shutdown when I hit the switch.

User avatar
Camble
Posts: 879
Joined: Thu May 05, 2016 2:31 am
Location: Scotland
Has thanked: 269 times
Been thanked: 487 times

Re: [Pre-Order] Safe Shutdown Switch (PowerBoost Version) - Closed

Post by Camble » Mon Feb 19, 2018 2:43 pm

garthster wrote:
Mon Feb 19, 2018 2:39 pm
How would I uninstall the power monitor script? Prolly a silly question, but I didn't seem to find instructions for that.
You would just remove the folder and re-clone the git repo.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest