SOLVED - Super AIO won't power off

Post Reply
cabnboy
Posts: 2
Joined: Wed May 13, 2020 7:07 pm

SOLVED - Super AIO won't power off

Post by cabnboy » Wed May 13, 2020 9:35 pm

I got my v0.6c Super AIO board in 2017. I finally got around to putting it all together (I know, it only took three years. I'm amazing. :lol: ). Everything is assembled and working well except it won't power off. I turn the switch off and it initiates the shutdown process. I see the stopped processes scroll by and the last line says power down then it goes to Kernel panic. The only way I can shut it down completely is to disconnect the power. It exhibits the same behavior whether powered by battery or USB. The battery charges when USB is plugged in.

When I connect the power it powers on no matter if the switch is in the on or off position. The only difference when the switch is in the off position the shutdown process starts as soon as the boot process is finished and it ends in Kernel panic. If the switch is in the on position when power is applied everything boots normally.

I'm not sure what to look for so any help would be greatly appreciated.
Last edited by cabnboy on Thu May 21, 2020 9:46 pm, edited 1 time in total.

cabnboy
Posts: 2
Joined: Wed May 13, 2020 7:07 pm

Re: Super AIO won't power off

Post by cabnboy » Thu May 21, 2020 9:35 pm

The original poster in this thread seemed to be having the same issue that I was. I took pictures with the switch on and the switch off. My pics look very much the same as the pics from this thread.
viewtopic.php?f=51&t=5118
Switch On.jpg
Power Switch Turned On
Switch On.jpg (167.9 KiB) Viewed 85 times
Switch Off.jpg
Power Switch Turned Off
Switch Off.jpg (208.89 KiB) Viewed 85 times
In that thread Kite was able to fix the board by replacing the transistor at Q10. I started trying to figure out if the Q10 transistor was bad on my SAIO. I noticed that Transistor at Q3 had the same markings. I started with a multi-meter gathering results between various pins for both resistance and voltage drop on the diode test. I compared the results from Q10 and Q3 and they did not match. I don't know too much about electronic components so even though my results didn't match, I wasn't sure if the component was bad. So I bought a cheap component tester on Amazon. I paid $12. The results are attached. Q3 identified as an NPN transistor. Q10 couldn't be identified. I was pretty sure at that point my Q10 transistor was bad.
Q10 Results.jpg
Q10 Transistor Results
Q10 Results.jpg (226.16 KiB) Viewed 85 times
Circuit Test.jpg
Q3 transistor results
Circuit Test.jpg (223.8 KiB) Viewed 85 times
Now knowing the transistor was bad, I started searching Google for the markings on that transistor. It had "AHW" and "P6". I couldn't find anything about this transistor with the googling that I did. I knew it was an NPN transistor and it was a SOT-23 form factor so I picked an SOT-23 NPN transistor on Amazon that was $6 for 200 of them! I needed one but who doesn't need 199 spares. I cut the leads on Q10 with a hobby knife to remove it. I cleaned up as best I could with the soldering Iron . I used some flux and then applied some solder past to the leads on the new transistor and used a soldering iron to finish the job.

I connected power to the system with no SD card. Power switch on the system powered up. Power switch off the system turned off. This was great progress since the power switch was not powering off the system before. I attached the screen and inserted my Retropie SD card. I turned the power switch on and everything booted up. I turned the switch off and waited a few seconds. Power down started normally and at the end The System powered off!!! Problem solved. I can now start to enjoy my Gameboy Zero.
Finished system.jpg
Finished Product. Yay!
Finished system.jpg (102.74 KiB) Viewed 85 times

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest