First power on test - USB / Arduino fail

User avatar
gilbertotron
Posts: 99
Joined: Mon Oct 24, 2016 10:07 am
Has thanked: 322 times
Been thanked: 25 times

Re: First power on test - USB / Arduino fail

Post by gilbertotron » Sat Mar 30, 2019 11:59 am

Hi Kite,

Sorry to resurrect an old post - I'm having this same issue - USBHUB is not lighting
Continuity between the pins is fine.
Is the USBHUB dead? And if so - is it fixable?

It was booting fine and working away - but not the power button is having no effect - If I short the pads POWER SWITCH on the board it boots normally...

User avatar
kite
Posts: 853
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 224 times
Been thanked: 301 times
Contact:

Re: First power on test - USB / Arduino fail

Post by kite » Sun Mar 31, 2019 1:20 am

Can you show pics of how the USB is soldered? It's all about the USB soldering (the USB data lines from pi to saio)

User avatar
gilbertotron
Posts: 99
Joined: Mon Oct 24, 2016 10:07 am
Has thanked: 322 times
Been thanked: 25 times

Re: First power on test - USB / Arduino fail

Post by gilbertotron » Sun Mar 31, 2019 10:25 am

Hi Kite,

Here are some images - are these any good to help diagnose?
SpoilerShow
Image
SpoilerShow
Image
SpoilerShow
Image
SpoilerShow
Image
EDIT: Google Photos is a pain - these were working - now moved to Imgur, can you see them now?
Sorry for the messing...
Last edited by gilbertotron on Mon Apr 01, 2019 5:03 am, edited 1 time in total.

User avatar
kite
Posts: 853
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 224 times
Been thanked: 301 times
Contact:

Re: First power on test - USB / Arduino fail

Post by kite » Mon Apr 01, 2019 3:22 am

gilbertotron wrote:
Sun Mar 31, 2019 10:25 am
Hi Kite,

Here are some images - are these any good to help diagnose?

..
I'm afraid those images don't show up, could you attach or upload somewhere public? (e.g. imgur)

User avatar
gilbertotron
Posts: 99
Joined: Mon Oct 24, 2016 10:07 am
Has thanked: 322 times
Been thanked: 25 times

Re: First power on test - USB / Arduino fail

Post by gilbertotron » Mon Apr 01, 2019 5:04 am

Hi Kite

Sorry Google Photo = pain
These should be working now. Sorry for the mistake.
Cheers

User avatar
kite
Posts: 853
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 224 times
Been thanked: 301 times
Contact:

Re: First power on test - USB / Arduino fail

Post by kite » Mon Apr 01, 2019 6:32 am

Those Pi USB solder pads, can you check with a DMM that they aren't shorted together (resistance/beep mode, and a probe on each of those pads).

Also, can you probe the back of the Pi USB connector and the connector on the board. DP should connect to DP and same for DM. These pics should help:

Image

Image

If all is lost, it is possible to wire it like so without using those solder holes:

Image

User avatar
gilbertotron
Posts: 99
Joined: Mon Oct 24, 2016 10:07 am
Has thanked: 322 times
Been thanked: 25 times

Re: First power on test - USB / Arduino fail

Post by gilbertotron » Mon Apr 01, 2019 6:53 am

Hi Kite,

DM - DM = continuity
DP - DP = continuity
DM - DP = no continuity on either pi or board.

Pi USB solder pads - I have not tested unfortunately - I will and get back to you - I never thought to check them... :oops:


Thanks for getting back to me.

User avatar
kite
Posts: 853
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 224 times
Been thanked: 301 times
Contact:

Re: First power on test - USB / Arduino fail

Post by kite » Mon Apr 01, 2019 8:17 am

When you say DP-DP continuity, from which DP to which DP are you measuring? It's important to do them as pictured above

User avatar
gilbertotron
Posts: 99
Joined: Mon Oct 24, 2016 10:07 am
Has thanked: 322 times
Been thanked: 25 times

Re: First power on test - USB / Arduino fail

Post by gilbertotron » Mon Apr 01, 2019 10:06 am

I did a continuity test from the pin you have labeled DP on the Pi's USB and the pin you have labeled DP on the AIO.
And the meter beeped - so i guess that there is continuity between those pins - the same happened with DM - DM
But there was no continuity between the pins DP-DM on the pi or the AIO.
Is that more clear? I'm unfortunately away from my home for a few days and so won't be able to test anything tonight.
Thanks for your help.

User avatar
kite
Posts: 853
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 224 times
Been thanked: 301 times
Contact:

Re: First power on test - USB / Arduino fail

Post by kite » Tue Apr 02, 2019 9:30 am

Ok I see, well that all sounds good to be honest! That is how it should be.

When in tester mode, they all say 'FAIL' right?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest