All in One PCB Support Thread

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2683
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1378 times
Been thanked: 3039 times

Re: All in One PCB Support Thread

Post by Helder » Mon Aug 08, 2016 3:31 pm

hueblo wrote:Hello @helder

If that post was meant for me I followed a3k4's template right before the 2.4 update. I have the AIO's negative and possitive hooked up through a bread board to the powerboost 1000C, the LCD and the pi0 are also hooked the same way. The D+ is hooked up to PP22 and D- is hooked up to PP23 of the pi0. Both the LCD and pi0 power up with no problem. I also tested the power to the AIO and did see 5V including the other USB ports. Like I said before it did work a few times and I was able to program the buttons through retropie but after hooking up the USB connector I made it started to have this detect issue. Any suggestions? Also can you confirm the wiring based on the images I provided as far is the D+/D- goes.
If the pi is recognizing the AIO board for controls it should be correct then for the D+ and D- . I have been talking about this over on the Discord channel and it seems like my board requires around 600-700mA if it's fully loaded with 3 usb devices which it isn't in your case so maybe show me pictures of the complete setup you have on the breadboard and what else you have powered.

We figured with the Gearbest screen and Pi Zero and my board it should take around 1-1.2A (with 3 usb devices) which is less than the 2A the powerboost supplies, maybe I'm wrong here but that seems to fit the bill in numbers.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
hueblo
Posts: 175
Joined: Mon Jun 06, 2016 2:59 pm
Has thanked: 78 times
Been thanked: 81 times

Re: All in One PCB Support Thread

Post by hueblo » Mon Aug 08, 2016 7:52 pm

@helder

You were right, currently my problem is current. Might be an issue with my power bost, If I power the AIO with a seperate power supply it works as soon as I run the AIO with the LCD and Pi0 it works intermittently. I got to figure it out I guess.

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2683
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1378 times
Been thanked: 3039 times

Re: All in One PCB Support Thread

Post by Helder » Mon Aug 08, 2016 8:13 pm

hueblo wrote:@helder

You were right, currently my problem is current. Might be an issue with my power bost, If I power the AIO with a seperate power supply it works as soon as I run the AIO with the LCD and Pi0 it works intermittently. I got to figure it out I guess.
What screen are you using? and perhaps show us some pictures of the whole thing, it's odd that the powerboost can't handle this all since it's supposed to pump out 2A of power. Are you using a battery in the testing?
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
hueblo
Posts: 175
Joined: Mon Jun 06, 2016 2:59 pm
Has thanked: 78 times
Been thanked: 81 times

Re: All in One PCB Support Thread

Post by hueblo » Mon Aug 08, 2016 9:37 pm

I'm using the adafruit screen. I do use a battery when testing. Currently the AIO is working running just of the battery to the 1000C. Before the only way i can get it to work with the current setup is to connect the micro usb to AC. It's possible the battery was low, the low battery led was not lot though. I'm going to fully charge the battery and test it all day tomorrow. Also I hooked up the speaker and the dmg headphone jack following a3k4's dmg diagram and it was not detected again, I disconnect headphone jack and speaker and it was detected again. Can you please confirm his dmg diagram is correct.

Image

Image

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2683
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1378 times
Been thanked: 3039 times

Re: All in One PCB Support Thread

Post by Helder » Mon Aug 08, 2016 11:26 pm

What's going on with the analog solder holes? I see them all wired but to where? If you're not using an analog stick you can just use 2 jumper wires front the X axis and Y axis to the GND hole on the Analog Stick area.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
hueblo
Posts: 175
Joined: Mon Jun 06, 2016 2:59 pm
Has thanked: 78 times
Been thanked: 81 times

Re: All in One PCB Support Thread

Post by hueblo » Tue Aug 09, 2016 6:54 am

I did hook up an analog stick, it's working.

Image

User avatar
Helder
Trailblazer
Trailblazer
Posts: 2683
Joined: Thu May 05, 2016 8:33 am
Location: Fall River, MA
Has thanked: 1378 times
Been thanked: 3039 times

Re: All in One PCB Support Thread

Post by Helder » Tue Aug 09, 2016 12:47 pm

What happens if you get 5v and GND from the powerboost for that USB socket? Also that screen is 350mA at 6v so I'm assuming it Close to 400mA with 5V. That's quite a it.
My Sale Threads:

Retro PSU, 3.5A output!


Chat with me and other members


Don't contact me about obtaining my board files (as you will not get them). Don't contact me about any of my boards if they are sold out, they will be restocked as soon as I can get them.


Don't support thieves like ckliang who copied my AIO to resell and is now cloning the mintyPi, support the original creators and not the thieves!

User avatar
hueblo
Posts: 175
Joined: Mon Jun 06, 2016 2:59 pm
Has thanked: 78 times
Been thanked: 81 times

Re: All in One PCB Support Thread

Post by hueblo » Tue Aug 09, 2016 8:51 pm

The AIO is still being detected. The only issue I'm having with the usb at the moment is a keyboard works when hooked up to the usb port but the wifi card gets power but not detected. Some one suggested to manually configure the wifi and reboot but I got the same result. The wifi blue led just stays solid, it does work when hooked up to my other pi with kodi.

User avatar
PotaTox
Posts: 128
Joined: Wed Jul 06, 2016 2:45 pm
Has thanked: 19 times
Been thanked: 19 times

Re: All in One PCB Support Thread

Post by PotaTox » Tue Aug 09, 2016 10:22 pm

hueblo wrote:The AIO is still being detected. The only issue I'm having with the usb at the moment is a keyboard works when hooked up to the usb port but the wifi card gets power but not detected. Some one suggested to manually configure the wifi and reboot but I got the same result. The wifi blue led just stays solid, it does work when hooked up to my other pi with kodi.
The problem here seems to be the usb wifi. Have you tried using it on anything other than the all in one hub or the raspberry pi? Maybe try plugging it in with an OTG adapter, or troubleshoot it with a computer. Anyway, you can still complete the Game Boy Zero without wifi, or maybe leave an open port inside the case so you can still work on the Game Boy without having to wait for another usb wifi chip (BTW I am no expert, don't expect me to solve all your problems)

User avatar
hueblo
Posts: 175
Joined: Mon Jun 06, 2016 2:59 pm
Has thanked: 78 times
Been thanked: 81 times

Re: All in One PCB Support Thread

Post by hueblo » Tue Aug 09, 2016 10:45 pm

PotaTox wrote:
hueblo wrote:The AIO is still being detected. The only issue I'm having with the usb at the moment is a keyboard works when hooked up to the usb port but the wifi card gets power but not detected. Some one suggested to manually configure the wifi and reboot but I got the same result. The wifi blue led just stays solid, it does work when hooked up to my other pi with kodi.
The problem here seems to be the usb wifi. Have you tried using it on anything other than the all in one hub or the raspberry pi? Maybe try plugging it in with an OTG adapter, or troubleshoot it with a computer. Anyway, you can still complete the Game Boy Zero without wifi, or maybe leave an open port inside the case so you can still work on the Game Boy without having to wait for another usb wifi chip (BTW I am no expert, don't expect me to solve all your problems)
It works with the pi0 with a different usb hub over otg. It works with my Windows 7 machine and works with a pi2 with kodi. I would like it to work so I can ssh into it if I have to make any changes, I know I can program it with the other hub but this is one of the reasons I got the AIO. :(

Locked

Who is online

Users browsing this forum: No registered users and 1 guest