(Solved) My start button is not working

Resolved mintyPi issues go here. Search this section first before creating a new support thread!
Billybobjoe
Posts: 9
Joined: Sat Nov 18, 2017 8:23 am
Has thanked: 3 times

(Solved) My start button is not working

Post by Billybobjoe » Sat Nov 18, 2017 8:33 am

Help please! I can't figure out what is happening but all of the sudden my start button just stopped working. :(
Last edited by Billybobjoe on Sat Nov 18, 2017 10:44 am, edited 1 time in total.

User avatar
dryja123
Posts: 1008
Joined: Tue May 09, 2017 5:34 pm
Location: Central NJ
Has thanked: 226 times
Been thanked: 527 times

Re: My start button is not working

Post by dryja123 » Sat Nov 18, 2017 8:34 am

Hey, happy to help. What have you done to troubleshoot so far?

Billybobjoe
Posts: 9
Joined: Sat Nov 18, 2017 8:23 am
Has thanked: 3 times

Re: My start button is not working

Post by Billybobjoe » Sat Nov 18, 2017 8:36 am

I have tried to return the card and tried to resolder the pi to the board but none of them worked

Billybobjoe
Posts: 9
Joined: Sat Nov 18, 2017 8:23 am
Has thanked: 3 times

Re: My start button is not working

Post by Billybobjoe » Sat Nov 18, 2017 8:39 am

Stupid autocorrect i meant reburn

User avatar
dryja123
Posts: 1008
Joined: Tue May 09, 2017 5:34 pm
Location: Central NJ
Has thanked: 226 times
Been thanked: 527 times

Re: My start button is not working

Post by dryja123 » Sat Nov 18, 2017 8:42 am

Do you have continuity from the GPIO to the start pad on the button PCB?

Billybobjoe
Posts: 9
Joined: Sat Nov 18, 2017 8:23 am
Has thanked: 3 times

Re: My start button is not working

Post by Billybobjoe » Sat Nov 18, 2017 9:08 am

Yes it has continuity from the pad to the gpio

User avatar
dryja123
Posts: 1008
Joined: Tue May 09, 2017 5:34 pm
Location: Central NJ
Has thanked: 226 times
Been thanked: 527 times

Re: My start button is not working

Post by dryja123 » Sat Nov 18, 2017 9:12 am

Does the start button work when you have the PCB out of the tin and while you have continuity?

Billybobjoe
Posts: 9
Joined: Sat Nov 18, 2017 8:23 am
Has thanked: 3 times

Re: My start button is not working

Post by Billybobjoe » Sat Nov 18, 2017 9:19 am

I will check in a minute

Billybobjoe
Posts: 9
Joined: Sat Nov 18, 2017 8:23 am
Has thanked: 3 times

Re: My start button is not working

Post by Billybobjoe » Sat Nov 18, 2017 9:50 am

Wow! It worked out of the tin

User avatar
dryja123
Posts: 1008
Joined: Tue May 09, 2017 5:34 pm
Location: Central NJ
Has thanked: 226 times
Been thanked: 527 times

Re: My start button is not working

Post by dryja123 » Sat Nov 18, 2017 10:13 am

Awesome! So here's what's going on, you have a poor solder connection from the Pi to the button PCB. When you screw everything down the PCB and the Pi flex, which breaks your connection. Reflow the solder in the GPIO and that should resolve your issue.

Post back with your results!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest