Circuit Gem stuck at login after RetroPie update

Get help with your VMµ build here!
Post Reply
User avatar
diko_d
Posts: 34
Joined: Mon May 08, 2017 5:18 pm
Has thanked: 27 times
Been thanked: 18 times

Circuit Gem stuck at login after RetroPie update

Post by diko_d » Fri Mar 01, 2019 11:45 am

Hey @kite,
After a successful build of the VMU, I ran a retropie update and now it just stops after boot waiting for login. The only additional thing I did that might affect this is that I also changed root password (passwd). I did change it back to default but still the same issue. Any ideas...?

sygyzy
Posts: 190
Joined: Tue Sep 05, 2017 12:45 pm
Has thanked: 52 times
Been thanked: 31 times

Re: Circuit Gem stuck at login after RetroPie update

Post by sygyzy » Wed Mar 06, 2019 12:02 pm

This is probably not what you want to hear but the easiest way to get you unblocked is to format the SD card and flash the stock image from Kite again. Often times custom projects like this requires a custom image because it needs to add low level support for things like the screen or custom scripts. Running retropie update can sometimes mess with this stuff. Go back to stock and ask Kite if you can run the update. Then look here to see how to update the Circuit Gem software - https://github.com/kiteretro/Circuit-Ge ... it-Gem-FAQ

User avatar
Robochris
Posts: 259
Joined: Thu Feb 16, 2017 7:49 am
Location: Ohio
Has thanked: 68 times
Been thanked: 36 times

Re: Circuit Gem stuck at login after RetroPie update

Post by Robochris » Wed Mar 06, 2019 2:15 pm

You need to ssh, go into the raspi-config and there is an auto login option in there somewhere, turn it on.

This is all off the top of my head so I can’t say for sure which options it’s under but I know it’s in raspi-config.
I’ve had several Pi’s do this to me after updates.

User avatar
diko_d
Posts: 34
Joined: Mon May 08, 2017 5:18 pm
Has thanked: 27 times
Been thanked: 18 times

Re: Circuit Gem stuck at login after RetroPie update

Post by diko_d » Fri Mar 08, 2019 9:16 am

Well, seems like RetroPie update breaks the auto-start behavior.
Eventually the fix is quite simple, so I decided to have it written here just in case others encounter this.

Considering the fact that in many cases you would actually desolder most of the connectors, including the USB connectors, so a headless configuration is very critical.

In order to enable SSH on first boot, just like you would add the wpa_supplicant.conf file to the boot folder, to have wifi setup for you on first boot you can also create an empty file called ssh in that folder. This will have SSH enabled with first boot. Assuming you added them both you can now SSH into your pi.

After a full RetroPie update, as mentioned above, your system will then stop at login upon first reboot.
Follow these steps:
* SSH into your VMu.
* Change folder to the RetroPie setup folder:

Code: Select all

cd RetroPie-Setup
* Run the RetroPie setup script:

Code: Select all

sudo ./retropie_setup.sh
* In RetroPie setup menu navigate to: Configuration / Tools -> Autostart
* Choose: Start Emulation Station at boot
* Reboot your RetroPie and you are all done!

Hope this helps anyone else stuck with this ;)

User avatar
kite
Posts: 798
Joined: Thu May 12, 2016 4:30 am
Location: UK
Has thanked: 212 times
Been thanked: 276 times
Contact:

Re: Circuit Gem stuck at login after RetroPie update

Post by kite » Fri Mar 08, 2019 9:29 am

Awesome :) Also don't forget for the Gem that the micro USB at the top is also an OTG port! So if you plug in an OTG adapter you can connect a USB keyboard etc without having to take anything apart :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest