TCB's V3 Build Log (Complete!)

Show off your completed mintyPi, or post your build logs here!
Post Reply
User avatar
The Cheese Biscuit
Posts: 36
Joined: Wed Aug 15, 2018 4:44 pm
Has thanked: 23 times
Been thanked: 25 times

TCB's V3 Build Log (Complete!)

Post by The Cheese Biscuit » Tue Apr 23, 2019 3:48 pm

Hello!

I've actually been working on this project a little bit here and there lately, but haven't made a whole lot of progress since we had the issues with the PCBs. I figured it would be pretty boring to make a build log and then not post anything for a couple of weeks.

Now that we have news of the fixed boards being shipped out soon (thanks again, Helder!), I feel like a build log would be fun!

So here's my progress so far:

I got the Practice boards a few months ago, and this was my first soldering attempt. The connections are all fine but the soldering itself needs a little work.
Practice Board #1Show
Image
A few weeks back I got my buttons and an awesome sticker (that I still need to find a place to put):
Buttons!Show
Image
After I had the buttons, I could start printing my parts to see which color combos I liked best. First I tested my print settings with some cheap PLA.
The Practice PrintsShow
Image
Once I got the print settings right, I brainstormed some color combos. I'm using a blue tin, but I don't want an overly blue face plate. I decided on doing something interesting. For the first two layers I printed in the cheap white PLA. It's somewhat translucent, especially when it's that thin. After the first two layers I switched to blue PLA. This gives the main parts of the face plates a bluish hue, and the indented details (like the Pi Logo and the Buttons) are a deeper blue. I may reprint this with the fan disabled to get a smoother finish.
FaceplatesShow
Image
Faceplates with buttonsShow
Image

Update (5/7):

Received a nicely packaged box in the mail... :D

Now I have my fresh-from-the-supplier PCB and my battery, so now assembly can start when all the parts are gathered.

Otherwise, I finished another practice board, this time all of the connections check out with no issues, only thing is that I probably could have been fine using less solder as not all of the solder is flush with the board.

As I am typing this, I'm reprinting an experimental face plate. Instead of the white PLA I used before, this time I used a translucent PLA. I also disabled the cooling fans on my printer and slowed down the print speed to try and get a smoother finish. The different plastic could also make a more interesting finish (plus, I barely have any plastic left on that spool, so this print should finish it off).


Update (5/11):

The experimental faceplates I printed the other day ended up looking terrible, so i'm sticking with the ones I made first.

Otherwise, I pretty much have all of my materials gathered, so today I started putting this together!
The StuffShow
Image
Today, I faced the task of soldering. Following Wermy's guide to the smallest detail, everything went smoothly. No major issues, only a couple of spots needed to be gone over a second time to push the solder into the pads. My multi meter said that everything was OK, and after booting it up, this went pretty well.
Solder PointsShow
Image
(The fluffy-looking stuff is pieces of the alcohol-soaked tissue I used to soak up the flux)


Update (5/13)

Yesterday I finished everything up! A lot went as planned, but some didn't go quite as well.

Drilling and filing holes into my tin was probably the hardest and most tedious part of the build. Some of the holes are just a little bit off, and I got some annoying scratches from the files.
Tin FrontShow
Image
Tin SideShow
Image
Tin BackShow
Image
After that, assembly went very smoothly. I didn't have any VHB on hand, so I used hot glue to mount the base and the screen.

Then, a couple of screws finished everything off and it was time to put some games on it! The only pictures I took of it working were when it was transferring, so I don't have any game play images (yet).
Transferring...Show
Image
All Working!Show
Image
I do only have one minor, but slightly aggravating issue. I forgot to add the magnet when I was putting the screen together, so I lost the ability for the auto-shutdown when the lid closes. Not a big issue at all, since I manually turn it off anyway, but I'll always know it's not there, and that's annoying. I guess I'll just save it for the next build... ;)


Thanks again to Wermy and Helder for making this project possible, and to everyone else who gave support both in the project's production as well as build issues. Your work is heavily appreciated!
"I'm not actually a biscuit."

User avatar
The Cheese Biscuit
Posts: 36
Joined: Wed Aug 15, 2018 4:44 pm
Has thanked: 23 times
Been thanked: 25 times

Re: TCB's V3 Build Log (Complete!)

Post by The Cheese Biscuit » Mon May 13, 2019 5:55 pm

Side note: is there a written guide anywhere for the function button shortcuts (aside from the volume, wifi and bluetooth toggles)? I know the button on the screen saves state, but how do you load that state when in a game? If this is already somewhere and I missed it, I apologize.
"I'm not actually a biscuit."

User avatar
LilTrublMakr
Posts: 238
Joined: Sun Aug 05, 2018 6:39 am
Has thanked: 23 times
Been thanked: 95 times
Contact:

Re: TCB's V3 Build Log (Complete!)

Post by LilTrublMakr » Mon May 13, 2019 7:18 pm

Function + screen button (save state button?)

MrErickson
Posts: 116
Joined: Sat Nov 04, 2017 3:04 pm
Has thanked: 36 times
Been thanked: 28 times

Re: TCB's V3 Build Log (Complete!)

Post by MrErickson » Tue May 14, 2019 11:47 am

Looks pretty slick, what color/brand of PLA didnyou use for your faceplates?

User avatar
The Cheese Biscuit
Posts: 36
Joined: Wed Aug 15, 2018 4:44 pm
Has thanked: 23 times
Been thanked: 25 times

Re: TCB's V3 Build Log (Complete!)

Post by The Cheese Biscuit » Tue May 14, 2019 5:44 pm

MrErickson wrote:
Tue May 14, 2019 11:47 am
Looks pretty slick, what color/brand of PLA didnyou use for your faceplates?
Thank You!

For the white on the front, I used something similar to this PLA. The exact brand I used isn't listed anymore, but it's basically really really cheap white filament.

For the layers behind the first two, I used this. I initially bought it at Micro Center, but this is the same brand and color.
"I'm not actually a biscuit."

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests